uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Eckart de Castilho (JIRA)" <...@uima.apache.org>
Subject [jira] [Commented] (UIMA-1524) JFSIndexRepository should be enhanced with new generic methods
Date Fri, 16 Sep 2016 20:58:20 GMT

    [ https://issues.apache.org/jira/browse/UIMA-1524?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15497345#comment-15497345
] 

Richard Eckart de Castilho commented on UIMA-1524:
--------------------------------------------------

2) ok, nice

4) +1

5) in my mind "offset" is quite strongly tied to the begin/end character offsets, so I find
it more attractive to use another them for skipping/seeking in the index. What makes you prefer
the argument form over the verb?

6) in uimaFIT, presently selectFollowing and selectPreceding both return the annotations in
index order. I don't have a strong opinion about selectPreceding returning in reverse index
order. Actually, I was my intuition that it would return in reverse order and I had to look
up the source code to figure out it was using index order.

7) I don't understand why reverse().reverse() should not be a no-op - if it is not a no-op,
then what is it? IMHO a positive offset/seek/skip should always go into iteration direction
and a negative should go opposite to the iteration direction. I believe it would utterly confuse
me if the offset/seek/skip would not follow the current iteration direction.

8) it could also be an option to have get() return null if there is no instance and throw
an exception only if there is more than one instance. Btw. do you fancy the use of Optional
in this new API? I'm not particularly fond of it (yet), but it seems some people are.

> JFSIndexRepository should be enhanced with new generic methods
> --------------------------------------------------------------
>
>                 Key: UIMA-1524
>                 URL: https://issues.apache.org/jira/browse/UIMA-1524
>             Project: UIMA
>          Issue Type: Improvement
>          Components: Core Java Framework
>    Affects Versions: 2.3
>            Reporter: Joern Kottmann
>
> Existing methods should be overloaded with an additional Class argument to specify the
exact return type. This changes make down casting of returned objects unnecessary. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message