uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marshall Schor (JIRA)" <...@uima.apache.org>
Subject [jira] [Commented] (UIMA-1524) JFSIndexRepository should be enhanced with new generic methods
Date Sat, 17 Sep 2016 16:02:20 GMT

    [ https://issues.apache.org/jira/browse/UIMA-1524?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15499257#comment-15499257

Marshall Schor commented on UIMA-1524:

Some of this discussion revolves around keyword and positional args. By "keywords", I'm thinking
keywords are when you use separate builder methods (whose names are like keywords) which then
act like keys for their args.  Positionals have the benefit of allowing more concise expression.

The value of having methods "following/preceding(...)" to me is when multiple positional args
are used; without them, following(10) is simply equivalent to the shorter and more standard
stream method "limit(10)", and preceding(10) is equivalent to .towardBegin().limit(10).  

The select(...) currently takes 0 or 1 argument (the type); so there's "room" for more positionals.
 One proposal from Richard seems nice: have the 2nd (or 2nd and additional) argument(s) be
a position or bound spec (4 forms:  fs, 2 ints representing begin/end, or either of these
plus a 3rd int: the "offset").  I think that the "position or bound specification" seems to
be the most frequently useful thing to have as the next positional arg for select.

> JFSIndexRepository should be enhanced with new generic methods
> --------------------------------------------------------------
>                 Key: UIMA-1524
>                 URL: https://issues.apache.org/jira/browse/UIMA-1524
>             Project: UIMA
>          Issue Type: Improvement
>          Components: Core Java Framework
>    Affects Versions: 2.3
>            Reporter: Joern Kottmann
> Existing methods should be overloaded with an additional Class argument to specify the
exact return type. This changes make down casting of returned objects unnecessary. 

This message was sent by Atlassian JIRA

View raw message