uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Eckart de Castilho (JIRA)" <...@uima.apache.org>
Subject [jira] [Commented] (UIMA-2971) Getters for boolean values in JCas wrappers don't follow common Java naming convention
Date Sun, 04 Sep 2016 15:18:20 GMT

    [ https://issues.apache.org/jira/browse/UIMA-2971?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15463066#comment-15463066
] 

Richard Eckart de Castilho commented on UIMA-2971:
--------------------------------------------------

When applying this already to V2, we could have getBoolean() and isBoolean() in parallel with
getBoolean() marked as deprecated. For V3, IMHO, getBoolean() should be dropped and only isBoolean()
should be kept.

> Getters for boolean values in JCas wrappers don't follow common Java naming convention
> --------------------------------------------------------------------------------------
>
>                 Key: UIMA-2971
>                 URL: https://issues.apache.org/jira/browse/UIMA-2971
>             Project: UIMA
>          Issue Type: Bug
>          Components: Core Java Framework
>            Reporter: Richard Eckart de Castilho
>             Fix For: 3.0.0SDKexp
>
>
> The getter generated for a boolean feature "XXX" in a JCas wrapper is called "getXXX".
It is a common Java convention, that getters for boolean values are called "isXXX".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message