uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Eckart de Castilho (JIRA)" <...@uima.apache.org>
Subject [jira] [Commented] (UIMA-2971) Getters for boolean values in JCas wrappers don't follow common Java naming convention
Date Sun, 04 Sep 2016 17:42:21 GMT

    [ https://issues.apache.org/jira/browse/UIMA-2971?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15463248#comment-15463248
] 

Richard Eckart de Castilho commented on UIMA-2971:
--------------------------------------------------

Keeping both names indefinitely doesn't seem a sensible option either. A major version step
is the best place to introduce breaking changes. The earlier the change is introduced into
V2 and the earlier the getBoolean methods are deprecated, the more advance warning time people
get.

> Getters for boolean values in JCas wrappers don't follow common Java naming convention
> --------------------------------------------------------------------------------------
>
>                 Key: UIMA-2971
>                 URL: https://issues.apache.org/jira/browse/UIMA-2971
>             Project: UIMA
>          Issue Type: Bug
>          Components: Core Java Framework
>            Reporter: Richard Eckart de Castilho
>             Fix For: 3.0.0SDKexp
>
>
> The getter generated for a boolean feature "XXX" in a JCas wrapper is called "getXXX".
It is a common Java convention, that getters for boolean values are called "isXXX".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message