uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marshall Schor (JIRA)" <...@uima.apache.org>
Subject [jira] [Commented] (UIMA-2971) Getters for boolean values in JCas wrappers don't follow common Java naming convention
Date Mon, 05 Sep 2016 15:29:20 GMT

    [ https://issues.apache.org/jira/browse/UIMA-2971?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15465244#comment-15465244
] 

Marshall Schor commented on UIMA-2971:
--------------------------------------

one other backwards compatible issue with making this change arises when and if the user (who
can customize the JCas code) might have written the isXXX style methods themselves, and could
have had it mean whatever they want.

> Getters for boolean values in JCas wrappers don't follow common Java naming convention
> --------------------------------------------------------------------------------------
>
>                 Key: UIMA-2971
>                 URL: https://issues.apache.org/jira/browse/UIMA-2971
>             Project: UIMA
>          Issue Type: Bug
>          Components: Core Java Framework
>            Reporter: Richard Eckart de Castilho
>             Fix For: 3.0.0SDKexp
>
>
> The getter generated for a boolean feature "XXX" in a JCas wrapper is called "getXXX".
It is a common Java convention, that getters for boolean values are called "isXXX".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message