uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marshall Schor (JIRA)" <...@uima.apache.org>
Subject [jira] [Commented] (UIMA-5127) uv3 make jcas backward compatible and no longer required
Date Thu, 06 Oct 2016 16:56:20 GMT

    [ https://issues.apache.org/jira/browse/UIMA-5127?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15552491#comment-15552491
] 

Marshall Schor commented on UIMA-5127:
--------------------------------------

Holding off doing this - it seems that it would be bad for backwards compatibility (ability
to use UIMA v3 to run with Jars compiled with v2 core), which is possible at the moment.

> uv3 make jcas backward compatible and no longer required
> --------------------------------------------------------
>
>                 Key: UIMA-5127
>                 URL: https://issues.apache.org/jira/browse/UIMA-5127
>             Project: UIMA
>          Issue Type: Task
>          Components: Core Java Framework
>            Reporter: Marshall Schor
>            Assignee: Marshall Schor
>             Fix For: 3.0.0SDKexp
>
>
> JCas is now mostly (if not entirely) just a trampoline to CAS and other objects. Complete
this transform.  Change the uses of jcas to work when passed the CAS instead - and deprecate
jcas use.  Change jcasgen to include new constructor that just takes the cas.  update all
uses of jcas to use the cas.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message