uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaroslaw Cwiklik <uim...@gmail.com>
Subject Re: [jira] [Created] (UIMA-5199) UIMA-AS should check for a core UIMA version no older than it
Date Tue, 06 Dec 2016 15:04:05 GMT
Ok, fixing the version checking using the following:

boolean majorMatch = UimaAsVersion.getMajorVersion() ==
UimaVersion.getMajorVersion();
boolean minorOK = UimaAsVersion.getMinorVersion() <=
UimaVersion.getMinorVersion();

 if ( !majorMatch || (majorMatch && !minorOK)  )
    throw Exception(...)

This allows UIMA-AS to work with uima core v2.9.0+, 2.10.+, etc  but not
core v3.x.x nor v2.8.x or
any version where a minor is below 9.



On Mon, Dec 5, 2016 at 11:07 AM, Burn Lewis (JIRA) <dev@uima.apache.org>
wrote:

> Burn Lewis created UIMA-5199:
> --------------------------------
>
>              Summary: UIMA-AS should check for a core UIMA version no
> older than it
>                  Key: UIMA-5199
>                  URL: https://issues.apache.org/jira/browse/UIMA-5199
>              Project: UIMA
>           Issue Type: Bug
>           Components: Async Scaleout
>             Reporter: Burn Lewis
>             Priority: Minor
>              Fix For: 2.9.0AS
>
>
> Perhaps check that the major is the same and the minor no older.  The 3rd
> digit could be ignored.  The versions will usually be identical since a
> matching version is included in the UIMA-AS package.
>
>
>
> --
> This message was sent by Atlassian JIRA
> (v6.3.4#6332)
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message