uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: [jira] [Updated] (UIMA-5291) UIMA-AS: eclipse update site missing from Eclipse install menus
Date Fri, 03 Feb 2017 19:15:24 GMT
Thanks for investigating...

I did an experiment that shows the problem to be some kind of incompatibility
between how the uimaj eclipse update site was updated for 3.0.0-alpha.

I built the uima-as 2.9.0 rc2 eclipse update site from source. 
I could get this to have the same failure if I first "looked at" (but didn't
install) the http://www.apache.org/dist/uima/eclipse-update-site, or the ...
/uima/eclipse-update-site/uimaj.

But this same built-from-sources version of the site on my local disk would work
if I "installed" the uimaj 2.9.0 plugins, and then attempted to install the
2.9.0 as plugins from my local "build-from-source" copy.  (wouldn't work from
the website dist source).

I think the cause might be that I built the Eclipse update site after I had
upgraded the Eclipse bundle packager and publisher, to use the version in
Eclipse Neon.2. 

I'll plan to do the following:
1) revert the eclipse update site, removing the 3.0.0.alpha release change. 
That should put it back into a work state for 2.9.0
2) change my settings file for eclipse update site building to use an older
level (Kepler?) of the Eclipse bundle publishing tool
3) do a new eclipse update subsite for 3.0.0 - something like
...dist/uima/eclipse-update-site/uimaj-v3 to keep the version 3 -alpha builds
separate (see https://issues.apache.org/jira/browse/UIMA-5294 )

-Marshall



On 2/3/2017 12:46 PM, Jaroslaw Cwiklik wrote:
> Checked eclipse log and got more details:
>
> Caused by: java.io.IOException:
> http://www.apache.org/dist/uima/eclipse-update-site/uima-as is not a valid
> repository location.
> at
> org.eclipse.equinox.internal.p2.metadata.repository.SimpleMetadataRepositoryFactory.load(SimpleMetadataRepositoryFactory.java:102)
>
> Source:
> https://github.com/irbull/rt.eclipse.p2/blob/master/bundles/org.eclipse.equinox.p2.metadata.repository/src/org/eclipse/equinox/internal/p2/metadata/repository/SimpleMetadataRepositoryFactory.java
>
> Looks like line 102:
>
> //if there is a jar but the entry is missing or invalid, treat this as an
> invalid repository
> if (jarEntry == null)
> throw new IOException(NLS.bind(Messages.repoMan_invalidLocation, location));
>
> So, this thing fails while handling a jar file. Something is missing from
> there.Still no clue what it might be. I have no recollection of changing
> anything in the plugins.
> -jerry
>
>
> On Fri, Feb 3, 2017 at 12:17 PM, Jaroslaw Cwiklik <uimaee@gmail.com> wrote:
>
>> Strange, install from local also fails. This error message ( "Unable to
>> read repository at..")  does not reveal much.
>>
>> -jerry
>>
>> On Thu, Feb 2, 2017 at 1:09 PM, Marshall Schor (JIRA) <dev@uima.apache.org
>>> wrote:
>>>      [ https://issues.apache.org/jira/browse/UIMA-5291?page=com.
>>> atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
>>>
>>> Marshall Schor updated UIMA-5291:
>>> ---------------------------------
>>>     Description:
>>> Noticed that UIMA-AS plugins are not showing on the Eclipse update site.
>>> A quick look seems to indicate they are there, so something has gone
>>> wrong.  Needs investigation.
>>>
>>> To reproduce: start a new fresh unzipped Eclipse (I used the current
>>> download - neon.2 ),
>>> Click on Install new software, and select http://www.apache.org/dist/uim
>>> a/eclipse-update-site/uima-as.  This produces:
>>> "Unable to read repository at http://www.apache.org/dist/uim
>>> a/eclipse-update-site/uima-as"
>>> caused by java.io.IOException: http://www.apache.org/dist/uim
>>> a/eclipse-update-site/uima-as is not a valid repository location.
>>>
>>>   was:Noticed that UIMA-AS plugins are not showing on the Eclipse update
>>> site.  A quick look seems to indicate they are there, so something has gone
>>> wrong.  Needs investigation.
>>>
>>>
>>>> UIMA-AS: eclipse update site missing from Eclipse install menus
>>>> ---------------------------------------------------------------
>>>>
>>>>                 Key: UIMA-5291
>>>>                 URL: https://issues.apache.org/jira/browse/UIMA-5291
>>>>             Project: UIMA
>>>>          Issue Type: Bug
>>>>          Components: Async Scaleout, Eclipse plugins
>>>>    Affects Versions: 2.9.0AS
>>>>            Reporter: Marshall Schor
>>>>            Assignee: Jerry Cwiklik
>>>>
>>>> Noticed that UIMA-AS plugins are not showing on the Eclipse update
>>> site.  A quick look seems to indicate they are there, so something has gone
>>> wrong.  Needs investigation.
>>>> To reproduce: start a new fresh unzipped Eclipse (I used the current
>>> download - neon.2 ),
>>>> Click on Install new software, and select
>>> http://www.apache.org/dist/uima/eclipse-update-site/uima-as.  This
>>> produces:
>>>> "Unable to read repository at http://www.apache.org/dist/uim
>>> a/eclipse-update-site/uima-as"
>>>> caused by java.io.IOException: http://www.apache.org/dist/uim
>>> a/eclipse-update-site/uima-as is not a valid repository location.
>>>
>>>
>>>
>>> --
>>> This message was sent by Atlassian JIRA
>>> (v6.3.15#6346)
>>>
>>


Mime
View raw message