uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaroslaw Cwiklik <uim...@gmail.com>
Subject Re: Eclipse update site building tools versions
Date Fri, 03 Feb 2017 21:32:46 GMT
I have no problem with upgrading to 4.3.2 (Keppler).

-jerry

On Fri, Feb 3, 2017 at 4:21 PM, Marshall Schor <msa@schor.com> wrote:

> Jerry says his build machine is set to a 3.7 level of Eclipse tooling (a
> very
> old level, dates from 2011).
>
> Mine was 4.3.2, but for last release I had upgraded to 4.6.2.  Maybe that's
> incompatible with the 3.7 tool chain generated artifacts.
>
> Waiting to hear from Peter, so we can converge more or less closely, if,
> indeed,
> this is the actual problem.
>
> -Marshall
>
>
> On 2/3/2017 3:55 PM, Marshall Schor wrote:
> > I think there's a good chance the reason the Eclipse update site broke
> with my
> > latest upload of 3.0.0.alpha was due to version changes in building
> tools.
> >
> > The tool chain version is configured typically in your .m2/settings.xml
> file, on
> > the lines that might look like the following
> >
> > <properties>
> >   <!-- Kepler 4.3.2 level -->
> >
> > <uima-maven-build-eclipse-home>C:/p/eclipse/432kepler</
> uima-maven-build-eclipse-home>
> > <!-- eclipse432 kepler -->
> >
> > <eclipse-equinox-launcher>${uima-maven-build-eclipse-home}
> /plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.
> jar</eclipse-equinox-launcher>
> >
> > <uima-eclipse-jar-processor>${uima-maven-build-eclipse-home}
> /plugins/org.eclipse.equinox.p2.jarprocessor_1.0.300.
> v20130327-2119.jar</uima-eclipse-jar-processor>
> >
> >   <!-- Neon 4.6.2 level -->
> >     <!--
> > uima-maven-build-eclipse-home>C:/p/eclipse/461neon</uima-
> maven-build-eclipse-home-->
> > <!-- eclipse462 neon.2 -->
> >     <!--
> > eclipse-equinox-launcher>${uima-maven-build-eclipse-home}
> /plugins/org.eclipse.equinox.launcher_1.3.201.v20161025-
> 1711.jar</eclipse-equinox-launcher-->
> >     <!--
> > uima-eclipse-jar-processor>${uima-maven-build-eclipse-home}
> /plugins/org.eclipse.equinox.p2.jarprocessor_1.0.500.
> v20160504-1450.jar</uima-eclipse-jar-processor-->
> >
> > Peter and Jerry, can you say what levels you have for building the
> plugins you
> > build?
> >
> > I'm trying to see if I can better understand the cause of the recent
> Eclipse
> > plugin repository errors.
> >
> > -Marshall
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message