uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaroslaw Cwiklik <uim...@gmail.com>
Subject Re: [jira] [Commented] (UIMA-5291) UIMA-AS: eclipse update site missing from Eclipse install menus
Date Mon, 06 Feb 2017 19:13:52 GMT
I initially copied right artifacts to the staging area to let people vote.
After the vote, I manually copied the artifacts to the Apache release site
and must have made a mistake in a process. Both artifacts.jar and
content.jar are identical there.

I rebuilt the uima-as eclipse update site today and was able to install it
in eclipse-keppler just fine. So there is no regression in a build.

No code changes have been made to the uima-as eclipse site since release
2.9.0. The only change I've made was in my mvn settings.xml to bring it up
to date. Modified eclipse-equinox-launcher and uima-eclipse-jar-processor
to point to keppler 4.3.2 level jars.

If there are no objections I will re-upload uima-as eclipse update site to
Apache in a few days.

Jerry



On Mon, Feb 6, 2017 at 9:57 AM, Marshall Schor (JIRA) <dev@uima.apache.org>
wrote:

>
>     [ https://issues.apache.org/jira/browse/UIMA-5291?page=com.atl
> assian.jira.plugin.system.issuetabpanels:comment-tabpanel&
> focusedCommentId=15854156#comment-15854156 ]
>
> Marshall Schor commented on UIMA-5291:
> --------------------------------------
>
> Problem root cause: faulty upload of content.jar.  This file in the
> build-from source is about 5K in size.  In the upload, it (and all of its
> signatures are a copy of the uploaded artifacts.jar.
>
>
>
> > UIMA-AS: eclipse update site missing from Eclipse install menus
> > ---------------------------------------------------------------
> >
> >                 Key: UIMA-5291
> >                 URL: https://issues.apache.org/jira/browse/UIMA-5291
> >             Project: UIMA
> >          Issue Type: Bug
> >          Components: Async Scaleout, Eclipse plugins
> >    Affects Versions: 2.9.0AS
> >            Reporter: Marshall Schor
> >            Assignee: Jerry Cwiklik
> >
> > Noticed that UIMA-AS plugins are not showing on the Eclipse update
> site.  A quick look seems to indicate they are there, so something has gone
> wrong.  Needs investigation.
> > To reproduce: start a new fresh unzipped Eclipse (I used the current
> download - neon.2 ),
> > Click on Install new software, and select http://www.apache.org/dist/uim
> a/eclipse-update-site/uima-as.  This produces:
> > "Unable to read repository at http://www.apache.org/dist/uim
> a/eclipse-update-site/uima-as"
> > caused by java.io.IOException: http://www.apache.org/dist/uim
> a/eclipse-update-site/uima-as is not a valid repository location.
>
>
>
> --
> This message was sent by Atlassian JIRA
> (v6.3.15#6346)
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message