uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marshall Schor (JIRA)" <...@uima.apache.org>
Subject [jira] [Resolved] (UIMA-5519) uv3 clarify use of ll_indexsize - used incorrectly in one spot
Date Fri, 01 Sep 2017 18:05:00 GMT

     [ https://issues.apache.org/jira/browse/UIMA-5519?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Marshall Schor resolved UIMA-5519.
    Resolution: Fixed

fixed in change set 1803725

> uv3 clarify use of ll_indexsize - used incorrectly in one spot
> --------------------------------------------------------------
>                 Key: UIMA-5519
>                 URL: https://issues.apache.org/jira/browse/UIMA-5519
>             Project: UIMA
>          Issue Type: Bug
>          Components: Core Java Framework
>            Reporter: Marshall Schor
>            Assignee: Marshall Schor
>             Fix For: 3.0.0SDK-beta
> Given an iterator, there are two definitions of index size.  One is the size as seen
by the iterator, which in v3, may not be the current index size (because iterators iterate
over a view of the index at a particular point in time - either the time of iterator creation,
or when a moveTo, moveToFirst, or moveToLast operation happens (except for snapshot iterators)).
 The other size is the current size of the index (and any sub-type indexes). 
> Change the name of the api to indicate this to reduce mistakes in the future.  Change
uses which are incorrect (which need the current index size).

This message was sent by Atlassian JIRA

View raw message