uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerry Cwiklik (JIRA)" <...@uima.apache.org>
Subject [jira] [Commented] (UIMA-5542) UIMA-DUCC: upgrade JNA or correct LICENSE
Date Wed, 03 Jan 2018 15:02:00 GMT

    [ https://issues.apache.org/jira/browse/UIMA-5542?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16309765#comment-16309765
] 

Jerry Cwiklik commented on UIMA-5542:
-------------------------------------

To use OS-based login for WS while running with IBM Java, the minimum JDK version is Java
8 SR4 FP5 (8.0.4.5)

> UIMA-DUCC: upgrade JNA or correct LICENSE
> -----------------------------------------
>
>                 Key: UIMA-5542
>                 URL: https://issues.apache.org/jira/browse/UIMA-5542
>             Project: UIMA
>          Issue Type: Bug
>          Components: DUCC
>            Reporter: Jerry Cwiklik
>            Assignee: Jerry Cwiklik
>             Fix For: 2.2.2-Ducc
>
>
> DUCC License says we depend on jna-4.2.2 which was true at some point. The ibm jvm had
some issues with that causing a hang. The parent pom dependency was changed to jna 4.0.0 but
LICENSE file had not been updated. Apparently ibm jvm was fixed (jdk8?) and is now happy with
a newer jna. If so we can upgrade jna for the next release.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message