uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerry Cwiklik (JIRA)" <...@uima.apache.org>
Subject [jira] [Updated] (UIMA-5694) UIMA-AS: Update README to say that user may need to run mvn with -U option
Date Mon, 08 Jan 2018 19:13:00 GMT

     [ https://issues.apache.org/jira/browse/UIMA-5694?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jerry Cwiklik updated UIMA-5694:
--------------------------------
    Description: 
The local m2 repo may get stale and builds may fail with strange errors like this:
[ERROR] Failed to execute goal on project uimaj-ep-deployeditor: Could not resolve dependencies
for project org.apache.uima:uimaj-ep-deployeditor:jar:2.10.2: Failed to collect dependencies
at org.eclipse.pde:org.eclipse.pde.ui:jar:3.9.100 -> org.eclipse.pde:org.eclipse.pde.core:jar:[3.6.0,4.0.0):
No versions available for org.eclipse.pde:org.eclipse.pde.core:jar:[3.6.0,4.0.0) within specified
range -> [Help 1] 

Modify README to tell a user to run mvn with -U option when strange errors happen. The default
build should *not* use -U as it forces maven to run a check on each dependency which may take
a long time.


  was:
The local m2 repo may get stale and builds may fail with strange errors like this:
[ERROR] Failed to execute goal on project uimaj-ep-deployeditor: Could not resolve dependencies
for project org.apache.uima:uimaj-ep-deployeditor:jar:2.10.2: Failed to collect dependencies
at org.eclipse.pde:org.eclipse.pde.ui:jar:3.9.100 -> org.eclipse.pde:org.eclipse.pde.core:jar:[3.6.0,4.0.0):
No versions available for org.eclipse.pde:org.eclipse.pde.core:jar:[3.6.0,4.0.0) within specified
range -> [Help 1] 

When building force maven to check for updated releases and snapshots on remote repositories
using this command:

mvn -U clean install

Note the -U which forces the update.

        Summary: UIMA-AS: Update README to say that user may need to run mvn with -U option
 (was: UIMA-AS: Update README to say that mvn -U should be used for building)

> UIMA-AS: Update README to say that user may need to run mvn with -U option
> --------------------------------------------------------------------------
>
>                 Key: UIMA-5694
>                 URL: https://issues.apache.org/jira/browse/UIMA-5694
>             Project: UIMA
>          Issue Type: Improvement
>          Components: Async Scaleout
>            Reporter: Jerry Cwiklik
>            Assignee: Jerry Cwiklik
>             Fix For: future-Uima-AS
>
>
> The local m2 repo may get stale and builds may fail with strange errors like this:
> [ERROR] Failed to execute goal on project uimaj-ep-deployeditor: Could not resolve dependencies
for project org.apache.uima:uimaj-ep-deployeditor:jar:2.10.2: Failed to collect dependencies
at org.eclipse.pde:org.eclipse.pde.ui:jar:3.9.100 -> org.eclipse.pde:org.eclipse.pde.core:jar:[3.6.0,4.0.0):
No versions available for org.eclipse.pde:org.eclipse.pde.core:jar:[3.6.0,4.0.0) within specified
range -> [Help 1] 
> Modify README to tell a user to run mvn with -U option when strange errors happen. The
default build should *not* use -U as it forces maven to run a check on each dependency which
may take a long time.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message