uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerry Cwiklik (JIRA)" <...@uima.apache.org>
Subject [jira] [Updated] (UIMA-5527) UIMA-DUCC: require java 1.8 for builds and runtime
Date Mon, 12 Feb 2018 21:41:00 GMT

     [ https://issues.apache.org/jira/browse/UIMA-5527?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jerry Cwiklik updated UIMA-5527:
--------------------------------
    Fix Version/s:     (was: future-DUCC)
                   2.2.2-Ducc

> UIMA-DUCC: require java 1.8 for builds and runtime
> --------------------------------------------------
>
>                 Key: UIMA-5527
>                 URL: https://issues.apache.org/jira/browse/UIMA-5527
>             Project: UIMA
>          Issue Type: Task
>          Components: DUCC
>            Reporter: Jerry Cwiklik
>            Assignee: Jerry Cwiklik
>            Priority: Major
>             Fix For: 2.2.2-Ducc
>
>
> Currently DUCC requires java 7 for maven builds. This version of java is quite old. We
should 
>  move up DUCC's java version to java 8 at minimum. Besides pom changes, the DUCC's javadoc
method headers must be changed to comply with a stricter syntax checking in version 8. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message