uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Eckart de Castilho (JIRA)" <...@uima.apache.org>
Subject [jira] [Commented] (UIMA-5753) Get UIMA compile on Java 9 and higher
Date Thu, 22 Mar 2018 14:17:00 GMT

    [ https://issues.apache.org/jira/browse/UIMA-5753?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16409585#comment-16409585
] 

Richard Eckart de Castilho commented on UIMA-5753:
--------------------------------------------------

I was just looking into getting the build to work, not into activating the feature of the
module system. It is kind of annoying to always have to switch back to an older JDK when doing
a build. I think we should treat aligning with the module system as a separate topic.

Although I got the build to work, I wasn't able to figure out where the extra line breaks
in the XML output come from. My best guess is that the handling on ignorable whitespace has
changed - but I have no idea how to counteract this change. The XML serialization code isn't
very straight-forward to read/understand.

> Get UIMA compile on Java 9 and higher
> -------------------------------------
>
>                 Key: UIMA-5753
>                 URL: https://issues.apache.org/jira/browse/UIMA-5753
>             Project: UIMA
>          Issue Type: Improvement
>          Components: Core Java Framework
>    Affects Versions: 2.10.2SDK
>            Reporter: Richard Eckart de Castilho
>            Assignee: Marshall Schor
>            Priority: Minor
>             Fix For: 3.0.1SDK, 2.10.3SDK
>
>
> Since meanwhile Java 10 has been released, seems like a good idea to get the build finally
running on Java 9 and higher.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message