uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KuiLIU (JIRA)" <...@uima.apache.org>
Subject [jira] [Created] (UIMA-5769) Inconsistent method name
Date Sat, 21 Apr 2018 20:45:00 GMT
KuiLIU created UIMA-5769:
----------------------------

             Summary: Inconsistent method name
                 Key: UIMA-5769
                 URL: https://issues.apache.org/jira/browse/UIMA-5769
             Project: UIMA
          Issue Type: Improvement
            Reporter: KuiLIU


The following method is named "toList" that seems like to convert one object to a list, but
the method just returns a list of FeatureStructure objects, so that the method name "getList"
should be more clear than "toList".
{code:java}
 /**
   * Retrieves a list of {@link FeatureStructure} objects.
   *
   * @return all selected {@link FeatureStructure} objects
   */
  public List<FeatureStructure> toList() {
    return mFeatureStructures;
  }
{code}





--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message