uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Eckart de Castilho (JIRA)" <...@uima.apache.org>
Subject [jira] [Updated] (UIMA-5769) Inconsistent method name
Date Sun, 22 Apr 2018 08:13:00 GMT

     [ https://issues.apache.org/jira/browse/UIMA-5769?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Richard Eckart de Castilho updated UIMA-5769:
---------------------------------------------
    Component/s: CAS Editor

> Inconsistent method name
> ------------------------
>
>                 Key: UIMA-5769
>                 URL: https://issues.apache.org/jira/browse/UIMA-5769
>             Project: UIMA
>          Issue Type: Improvement
>          Components: CAS Editor
>            Reporter: KuiLIU
>            Priority: Major
>
> The following method is named "toList" that seems like to convert one object to a list,
but the method just returns a list of FeatureStructure objects, so that the method name "getList"
should be more clear than "toList".
> {code:java}
>  /**
>    * Retrieves a list of {@link FeatureStructure} objects.
>    *
>    * @return all selected {@link FeatureStructure} objects
>    */
>   public List<FeatureStructure> toList() {
>     return mFeatureStructures;
>   }
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message