uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marshall Schor (JIRA)" <...@uima.apache.org>
Subject [jira] [Commented] (UIMA-5769) Inconsistent method name
Date Sun, 22 Apr 2018 21:06:00 GMT

    [ https://issues.apache.org/jira/browse/UIMA-5769?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16447373#comment-16447373

Marshall Schor commented on UIMA-5769:

Changing this (public) method name could impact all users of this method - their code would
no longer work...  Because we want users to be able to invest in their code which relies
on UIMA, with the assurance that it will continue to be able to work going forward with future
releases, we are generally reluctant to change public APIs unless there's a significant benefit
to the change. 
 * There are exceptions, of course (note UIMA V3 as a major one), but these typically have
other major benefits.

> Inconsistent method name
> ------------------------
>                 Key: UIMA-5769
>                 URL: https://issues.apache.org/jira/browse/UIMA-5769
>             Project: UIMA
>          Issue Type: Improvement
>          Components: CAS Editor
>            Reporter: KuiLIU
>            Priority: Major
> The following method is named "toList" that seems like to convert one object to a list,
but the method just returns a list of FeatureStructure objects, so that the method name "getList"
should be more clear than "toList".
> {code:java}
>  /**
>    * Retrieves a list of {@link FeatureStructure} objects.
>    *
>    * @return all selected {@link FeatureStructure} objects
>    */
>   public List<FeatureStructure> toList() {
>     return mFeatureStructures;
>   }
> {code}

This message was sent by Atlassian JIRA

View raw message