uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Eckart de Castilho <...@apache.org>
Subject Re: maven prerequisite clause giving complaint of improper use
Date Wed, 03 Oct 2018 08:10:37 GMT
On 2. Oct 2018, at 16:16, Marshall Schor <msa@schor.com> wrote:
> 
> The prerequisites clause is still useful for some of our projects which **are**
> maven plugin.  The Maven Model docs say:
> 
> In Maven 2, this was also specifying the minimum version of Maven required to
> build a project,
> but this usage is deprecated in Maven 3 and not checked any more...

It should be sufficient to declare the prerequisites in the actual maven plugin
modules instead of declaring it in the overall parent pom.

In order to still centrally configure the minimum maven version from the parent
pom, it may be possible to declare a property which would then be used in the
prerequisites section of the maven plugin module's poms.

-- Richard
Mime
View raw message