uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Klügl (Jira) <...@uima.apache.org>
Subject [jira] [Commented] (UIMA-6213) Ruta: LayerInstantiationException in LaunchDelegate using newer Java versions
Date Thu, 09 Apr 2020 13:48:00 GMT

    [ https://issues.apache.org/jira/browse/UIMA-6213?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17079358#comment-17079358
] 

Peter Klügl commented on UIMA-6213:
-----------------------------------

Investigation by Marshall:

I tried the following:

1) in an environment with Java 13 installed, and Eclipse 4.15.0  (2020-03):

make a new Java project, with a main class that does System.out.println("here");

run it, and look at the launch configuration, it doesn't have the -p
C:\p\j\oracle13.0.2\lib\jrt-fs.jar
in the command line.

2) in that same environment, doing a Ruta launch somehow results in inserting that.

If you can figure out how to change whatever you've done to configure the launch
spec, that might fix things.

More:  The Run Configuration tab for Main.ruta / Classpath shows like java 8
version.
The Run Configuration for the new test project / doesn't even have a
"classpath", tab,
it has a "Dependencies" tab, which has much the same content, but includes both
   Classpath Entries and
   Modulepath Entries,

and has an addition section at the bottom labeled "Add modules:"

Fiddled with this , but never got the command line to include the -p ...jrt-fs.jar.

> Ruta: LayerInstantiationException in LaunchDelegate using newer Java versions
> -----------------------------------------------------------------------------
>
>                 Key: UIMA-6213
>                 URL: https://issues.apache.org/jira/browse/UIMA-6213
>             Project: UIMA
>          Issue Type: Bug
>          Components: Ruta
>    Affects Versions: 3.0.0ruta, 2.8.0ruta
>            Reporter: Peter Klügl
>            Priority: Major
>
> When runnung a script in a simple Ruta project:
> Error occurred during initialization of boot layer: java.lang.LayerInstantiationException:
Package jdk.internal.jimage in both module jrt.fs and java.base 
> (Eclipse running on OpenJDK 13)



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message