uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Eckart de Castilho (Jira)" <...@uima.apache.org>
Subject [jira] [Updated] (UIMA-6267) UIMA SDK Eclipse Plugins fail to build after Eclipse 2020-09 release
Date Thu, 17 Sep 2020 20:45:00 GMT

     [ https://issues.apache.org/jira/browse/UIMA-6267?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Richard Eckart de Castilho updated UIMA-6267:
---------------------------------------------
    Description: 
Since the Eclipse 2020-09 was released, it appears some JARs the UIMA Eclipse plugins transitively
on Maven Central have been updated and some of them are actually missing from Maven Central:

{quote}
[ERROR] Failed to execute goal on project uimaj-ep-debug: Could not resolve dependencies for
project org.apache.uima:uimaj-ep-debug:jar:2.10.5-SNAPSHOT: Failed to collect dependencies
at org.eclipse.jdt:org.eclipse.jdt.debug.ui:jar:3.8.0 -> org.eclipse.platform:org.eclipse.ui.workbench.texteditor:jar:3.10.1
-> org.eclipse.platform:org.eclipse.ui:jar:3.108.1 -> org.eclipse.platform:org.eclipse.ui.workbench:jar:3.108.2
-> org.eclipse.platform:org.eclipse.e4.ui.workbench.swt:jar:0.14.1000 -> org.eclipse.platform:org.eclipse.urischeme:jar:1.1.100
-> com.sun.jna:com.sun.jna:jar:[4.5.1,6.0.0): No versions available for com.sun.jna:com.sun.jna:jar:[4.5.1,6.0.0)
within specified range -> [Help 1]
{quote}

When excluding the JNA dependencies, we get another error:

{quote}
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.0:compile
(default-compile) on project uimaj-ep-debug: Compilation failure
[ERROR] /home/jenkins/jenkins-agent/workspace/UIMA_uima-uimaj_PR-56/uimaj-ep-debug/src/main/java/org/apache/uima/ep_debug/DebugPlugin.java:[23,41]
cannot access org.eclipse.jdt.internal.debug.ui.IJDIPreferencesConstants
[ERROR]   bad class file: /home/jenkins/.m2/repository/org/eclipse/jdt/org.eclipse.jdt.debug.ui/3.12.0/org.eclipse.jdt.debug.ui-3.12.0.jar(org/eclipse/jdt/internal/debug/ui/IJDIPreferencesConstants.class)
[ERROR]     class file has wrong version 55.0, should be 52.0
[ERROR]     Please remove or make sure it appears in the correct subdirectory of the classpath.
{quote}

Eclipse 2020-09 requires Java 11. Looks like we'd need to cap the max version of the {{org.eclipse.jdt.debug.ui}}
dependency to e.g. 3.10.500. However, it we add that to the POM I'm afraid it may mean that
we'd be unable to install the UIMA on the > 2020-09 versions of Eclipse despite them being
in principle API compatible....

So we'd have to run the UIMA builds with a Java 11 or higher....

  was:
Since the Eclipse 2020-09 was released, it appears some JARs the UIMA Eclipse plugins transitively
on Maven Central have been updated and some of them are actually missing from Maven Central:

{quote}
[ERROR] Failed to execute goal on project uimaj-ep-debug: Could not resolve dependencies for
project org.apache.uima:uimaj-ep-debug:jar:2.10.5-SNAPSHOT: Failed to collect dependencies
at org.eclipse.jdt:org.eclipse.jdt.debug.ui:jar:3.8.0 -> org.eclipse.platform:org.eclipse.ui.workbench.texteditor:jar:3.10.1
-> org.eclipse.platform:org.eclipse.ui:jar:3.108.1 -> org.eclipse.platform:org.eclipse.ui.workbench:jar:3.108.2
-> org.eclipse.platform:org.eclipse.e4.ui.workbench.swt:jar:0.14.1000 -> org.eclipse.platform:org.eclipse.urischeme:jar:1.1.100
-> com.sun.jna:com.sun.jna:jar:[4.5.1,6.0.0): No versions available for com.sun.jna:com.sun.jna:jar:[4.5.1,6.0.0)
within specified range -> [Help 1]
{quote}


> UIMA SDK Eclipse Plugins fail to build after Eclipse 2020-09 release
> --------------------------------------------------------------------
>
>                 Key: UIMA-6267
>                 URL: https://issues.apache.org/jira/browse/UIMA-6267
>             Project: UIMA
>          Issue Type: Bug
>          Components: Eclipse plugins
>            Reporter: Richard Eckart de Castilho
>            Priority: Major
>
> Since the Eclipse 2020-09 was released, it appears some JARs the UIMA Eclipse plugins
transitively on Maven Central have been updated and some of them are actually missing from
Maven Central:
> {quote}
> [ERROR] Failed to execute goal on project uimaj-ep-debug: Could not resolve dependencies
for project org.apache.uima:uimaj-ep-debug:jar:2.10.5-SNAPSHOT: Failed to collect dependencies
at org.eclipse.jdt:org.eclipse.jdt.debug.ui:jar:3.8.0 -> org.eclipse.platform:org.eclipse.ui.workbench.texteditor:jar:3.10.1
-> org.eclipse.platform:org.eclipse.ui:jar:3.108.1 -> org.eclipse.platform:org.eclipse.ui.workbench:jar:3.108.2
-> org.eclipse.platform:org.eclipse.e4.ui.workbench.swt:jar:0.14.1000 -> org.eclipse.platform:org.eclipse.urischeme:jar:1.1.100
-> com.sun.jna:com.sun.jna:jar:[4.5.1,6.0.0): No versions available for com.sun.jna:com.sun.jna:jar:[4.5.1,6.0.0)
within specified range -> [Help 1]
> {quote}
> When excluding the JNA dependencies, we get another error:
> {quote}
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.0:compile
(default-compile) on project uimaj-ep-debug: Compilation failure
> [ERROR] /home/jenkins/jenkins-agent/workspace/UIMA_uima-uimaj_PR-56/uimaj-ep-debug/src/main/java/org/apache/uima/ep_debug/DebugPlugin.java:[23,41]
cannot access org.eclipse.jdt.internal.debug.ui.IJDIPreferencesConstants
> [ERROR]   bad class file: /home/jenkins/.m2/repository/org/eclipse/jdt/org.eclipse.jdt.debug.ui/3.12.0/org.eclipse.jdt.debug.ui-3.12.0.jar(org/eclipse/jdt/internal/debug/ui/IJDIPreferencesConstants.class)
> [ERROR]     class file has wrong version 55.0, should be 52.0
> [ERROR]     Please remove or make sure it appears in the correct subdirectory of the
classpath.
> {quote}
> Eclipse 2020-09 requires Java 11. Looks like we'd need to cap the max version of the
{{org.eclipse.jdt.debug.ui}} dependency to e.g. 3.10.500. However, it we add that to the POM
I'm afraid it may mean that we'd be unable to install the UIMA on the > 2020-09 versions
of Eclipse despite them being in principle API compatible....
> So we'd have to run the UIMA builds with a Java 11 or higher....



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message