usergrid-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mru...@apache.org
Subject [2/3] usergrid git commit: PATCH - Updated Portal Dependencies
Date Sat, 29 Dec 2018 19:10:09 GMT
PATCH - Updated Portal Dependencies

Portal will now build without errors.


Project: http://git-wip-us.apache.org/repos/asf/usergrid/repo
Commit: http://git-wip-us.apache.org/repos/asf/usergrid/commit/4fd27f12
Tree: http://git-wip-us.apache.org/repos/asf/usergrid/tree/4fd27f12
Diff: http://git-wip-us.apache.org/repos/asf/usergrid/diff/4fd27f12

Branch: refs/heads/master
Commit: 4fd27f12e440639de829fffb3b3bc424616f0b25
Parents: 0755778
Author: Joost van Ulden <joost@vanulden.com>
Authored: Tue Aug 28 20:26:39 2018 -0700
Committer: Joost van Ulden <joost@vanulden.com>
Committed: Tue Aug 28 20:26:39 2018 -0700

----------------------------------------------------------------------
 portal/Gruntfile.js |  2 +-
 portal/package.json | 51 +++++++++++++++++++++++++-----------------------
 2 files changed, 28 insertions(+), 25 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/usergrid/blob/4fd27f12/portal/Gruntfile.js
----------------------------------------------------------------------
diff --git a/portal/Gruntfile.js b/portal/Gruntfile.js
index f0cdc94..9ea0c43 100644
--- a/portal/Gruntfile.js
+++ b/portal/Gruntfile.js
@@ -94,7 +94,7 @@ module.exports = function(grunt) {
           mangle: false,
           compress: false,
           beautify: true,
-          wrap: true
+          wrap: false
         },
         files: {
           'js/generated/usergrid-dev.js': [

http://git-wip-us.apache.org/repos/asf/usergrid/blob/4fd27f12/portal/package.json
----------------------------------------------------------------------
diff --git a/portal/package.json b/portal/package.json
index 74a68ac..8b7588f 100644
--- a/portal/package.json
+++ b/portal/package.json
@@ -1,5 +1,5 @@
 {
-  "name": "usergrid", 
+  "name": "usergrid",
   "version": "2.0.19",
   "packageName": "appsvc-ui",
   "description": "full usergrid portal",
@@ -9,37 +9,40 @@
     "url": "https://github.com/usergrid/usergrid.git"
   },
   "devDependencies": {
-    "chromedriver": "~2.10.0-1",
-    "grunt": "~0.4.4",
-    "grunt-cli": "~0.1.11",
-    "grunt-contrib-cssmin": "~0.7.0",
-    "grunt-contrib-uglify": "~0.2.7",
+    "bower": "~1.2.8",
+    "chromedriver": "^2.41.0",
+    "grunt": ">=0.4.5 <1.0.0",
     "grunt-angular-templates": "~0.4.7",
-    "grunt-contrib-watch": "~0.5.3",
-    "grunt-contrib-connect": "~0.5.0",
+    "grunt-bower-task": "^0.5.0",
+    "grunt-cli": "^1.3.1",
+    "grunt-contrib-clean": "~0.4.0",
+    "grunt-contrib-compress": "^1.4.3",
     "grunt-contrib-concat": "~0.3.0",
-    "karma-script-launcher": "~0.1.0",
+    "grunt-contrib-connect": "^1.0.2",
+    "grunt-contrib-copy": "~0.4.1",
+    "grunt-contrib-cssmin": "~0.7.0",
+    "grunt-contrib-uglify": "^3.4.0",
+    "grunt-contrib-watch": "^1.1.0",
+    "grunt-dom-munger": "~3.1.0",
+    "grunt-istanbul": "^0.8.0",
+    "grunt-karma": "2.0.0",
+    "grunt-protractor-runner": "^5.0.0",
+    "karma": "^3.0.0",
     "karma-chrome-launcher": "~0.1.1",
-    "karma-html2js-preprocessor": "~0.1.0",
+    "karma-coffee-preprocessor": "~0.1.1",
     "karma-firefox-launcher": "~0.1.2",
+    "karma-html2js-preprocessor": "~0.1.0",
     "karma-jasmine": "~0.1.3",
-    "karma-coffee-preprocessor": "~0.1.1",
-    "requirejs": "~2.1.9",
+    "karma-phantomjs-launcher": "^1.0.4",
     "karma-requirejs": "~0.2.0",
-    "karma-phantomjs-launcher": "~0.1.1",
-    "karma": "~0.10.8",
-    "grunt-karma": "~0.6.2",
-    "protractor": "~0.22.0",
-    "grunt-protractor-runner": "~0.2.0",
-    "grunt-contrib-copy": "~0.4.1",
-    "grunt-contrib-compress": "~0.12.0",
-    "grunt-contrib-clean": "~0.4.0",
-    "grunt-dom-munger": "~3.1.0",
-    "bower": "~1.2.8",
-    "grunt-bower-task": "~0.4.0",
-    "grunt-istanbul": "~0.2.5"
+    "karma-script-launcher": "~0.1.0",
+    "protractor": "^5.4.0",
+    "requirejs": "~2.1.9"
   },
   "engines": {
     "node": ">=0.10.21"
+  },
+  "dependencies": {
+    "grunt-jslint": "^1.1.15"
   }
 }


Mime
View raw message