velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christoph Reck <>
Subject Re: AW: AW: introspection 'enhancement'
Date Fri, 02 Feb 2001 11:26:20 GMT
Thomas Fahrmeyer wrote:
> I looked in the Bean 1.01 spec for the naming conventions of accessor
> methods.
> You are right Geir. It is not defined to write "getMethod" but it's
> explicitly described in the accessor design pattern chapter of the spec.

The capitalization *is* explicetely stated (as the inverse when 
going from a method- or listener name to the property name). See
section "8.8 Capitalization of inferred names" of the Bean 1.01 
spec. It also states: "the name will, by default, begin with a 
capital letter." 

Inverting this rule makes the uppercasing the first letter to 
define the setter method conform with the spec.

:) Christoph

View raw message