velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geir Magnusson Jr." <>
Subject Re: AW: introspection 'enhancement'
Date Sat, 03 Feb 2001 03:37:21 GMT
Christoph Reck wrote:
> OK, I didn't vote against your enhancement, I just was echoing
> the "keep it(Velocity) simple" recommendation!
> I don't care if it's $foo.Bar or $ (which looks nicer
> and is more what Java pople are acustomed).

What the code does is :

$foo.Bar  ->  getBar() and then getbar() if getBar() failed
$  ->  getbar() and then getBar() if getbar() failed

Then, after reading your post, I figured/suggested/agreed that we should
always do getBar() first, because that is most likely what will be in
the code, then getbar() for the nonconformists...

> > Right.  But we don't require that objects in the context are beans...
> > It's helpful, but not required.
> If you try getBar() before getbar(), I don't mind the (size)overhead,
> it's fine with me...
> Thanks for your good moderating and sweat/frustration with Vel.
> :) Christoph

Geir Magnusson Jr.                     
Velocity : it's not just a good idea. It should be the law.

View raw message