velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Fahrmeyer" <thomas.fahrme...@einsurance.de>
Subject AW: AW: introspection 'enhancement'
Date Fri, 02 Feb 2001 11:12:47 GMT
I looked in the Bean 1.01 spec for the naming conventions of accessor
methods.

You are right Geir. It is not defined to write "getMethod" but it's
explicitly described
in the accessor design pattern chapter of the spec.

> -----Ursprungliche Nachricht-----
> Von: gmj@optonline.net [mailto:gmj@optonline.net]Im Auftrag von Geir
> Magnusson Jr.
> Gesendet: Freitag, 2. Februar 2001 12:33
> An: velocity-user@jakarta.apache.org
> Betreff: Re: AW: introspection 'enhancement'
>
>
> Thomas Fahrmeyer wrote:
> >
> > Hi,
> >
> > I asked for that ;)
>
> Ya got it...
>
> >
> > It's a very flexible approach, but is it not too complicate ?
> The Bean spec
> > says that after a "get" or "set" (in a method name) must follow
> a uppercase
> > letter. So expect that a method in this signature is defined.
> And now just
> > convert the first letter of every property to uppercase and lool up the
> > method.
>
> I don't think the bean spec actually states this, but if you can tell me
> where, I would be happy to know.
>
> We *infer* this, but as far as I can tell, it doesn't say it.
>
> >
> > I think that makes the designer life easier and the programmer
> knows what he
> > have to do anyway (mostly) ;)
>
> agreed
>
> > It's just very nice to write $user.name instead of $user.Name
> >
> > Thomas
>
>
> --
> Geir Magnusson Jr.                               geirm@optonline.com
> Velocity : it's not just a good idea. It should be the law.
> http://jakarta.apache.org/velocity


Mime
View raw message