velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geir Magnusson Jr." <ge...@optonline.net>
Subject Re: new webapp for SampleServlet
Date Thu, 12 Jul 2001 02:15:30 GMT
Eric Handbury wrote:
> 
> Hello,
> 
>   I'm new to servlets and velocity.
> 
>   I got servlet_example1 to work no problem, however I am trying to move the
> program to my own webapp. So I did the following:
> 
>   1) mkdir on /home/httpd/htdocs/webapps/mine
>   2) mkdir'd WEB-INF, lib, classes, and added the files exactly like the
> velexample in servlet_example1.
>   3) Added the context /mine in servlet.xml with docBase being
> /home/httpd/htdocs/webapps/mine.
> 
>   Everything works except for the /home/httpd/htdocs/webapps/mine/sample.vm
> is not found.

That really works?

My suggestion would be to *not* mix the servlet webapps in the apache
tree.  What servlet runner?  Tomcat?

Did you adjust the velocity.properties file to reflect the new position
of the template?

Remember, you either have to setup that explicitly, or use a method like
in servlet_example2 to get the servlet runner to convert a path relative
to your webapp root to the absolute path.

See servlet_example2.

geir

-- 
Geir Magnusson Jr.                           geirm@optonline.net
System and Software Consulting
Developing for the web?  See http://jakarta.apache.org/velocity/
You have a genius for suggesting things I've come a cropper with!

Mime
View raw message