velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Cuevas <ecuev...@iac.com.mx>
Subject Re: Problems with navigation on templates
Date Fri, 02 Nov 2001 16:18:22 GMT
Well, I don't tjink it's for thr turbine list, 'case I'm usin' Velocimacros, and I
feel this question belongs here....   =)

What I'm traing to do, is tho have a page with two dynamic elements without using
frames....

Cheers !!

Dan Bachelder escribió:

> this is a turbine question right? you might try the turbine list... I use
> turbine, but i have not had the need to do what you are doing... sorry..
>
> ----- Original Message -----
> From: Emmanuel Cuevas
> To: Velocity Users List
> Sent: Thursday, November 01, 2001 10:25 AM
> Subject: Re: Problems with navigation on templates
>
> Hello !!
> Right now im thinking in changin the structure, buet I'd like to know if I
> can have 2 screen_placeholders... here is my code, but I want to add an
> additional
> screen_placeholder but I cannot find if this is posible, in the
> documentation says nothing about this issue...
> here is my current code:
> <table width="100%">
>   <tr>
>     <td colspan="2">
>       $navigation.setTemplate("/DefaultTop.vm")
>     </td>
>   </tr>
>   <tr>
>     <td align="left" valign="top">
>       $screen_placeholder
>     </td>
>     <td width="20" align="right" valign="top">
>       $navigation.setTemplate("/Menu.vm")
>     </td>
>   </tr>
>   <tr>
>     <td colspan="2">
>       $navigation.setTemplate("/DefaultBottom.vm")
>     </td>
>   </tr>
> </table>
> It belongs to my Default.vm file, and here is where I want to add the other
> screen_placeholder.
> Any thoughts ???
> Thanks in advance !!!
>
> Dan Bachelder escribió:
> Are you using #include()? you should use #parse() if you want velocity to
> parse the file.... otherwise its just like doing a SSI..
> ----- Original Message -----
> From: Emmanuel Cuevas
> To: Velocity Users List
> Sent: Wednesday, October 31, 2001 11:47 AM
> Subject: Problems with navigation on templates
> Hi everyone !!
> I it seems that no long ago I replied an email by accident, sorry  =)
> Well, here is my problem:
> I want to use more than one template for formating a web page,
> but when I try to load a navigation template from a screen template
> I just a web page showing the variable names but without format nor data.
> I'd like to know how can I achieve such loading process !!
> Any suggestion ??
> Thanks in advance
> --
> Emmanuel Cuevas
> Senior Developer
> ecuevasr@iac.com.mx
> "If you gotta go, go with a smile"
>                         The Joker
> --
> To unsubscribe, e-mail:
> <mailto:velocity-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:velocity-user-help@jakarta.apache.org>
> --
> To unsubscribe, e-mail:
> <mailto:velocity-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:velocity-user-help@jakarta.apache.org>
> --
> Emmanuel Cuevas
> Senior Developer
>
> ecuevasr@iac.com.mx
>
> "If you gotta go, go with a smile"
>                         The Joker
>
> --
> To unsubscribe, e-mail:
> <mailto:velocity-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:velocity-user-help@jakarta.apache.org>
>
> --
> To unsubscribe, e-mail:   <mailto:velocity-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:velocity-user-help@jakarta.apache.org>

--
Emmanuel Cuevas
Senior Developer

ecuevasr@iac.com.mx

"If you gotta go, go with a smile"
                        The Joker



Mime
View raw message