velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geir Magnusson Jr." <ge...@adeptra.com>
Subject Re: Jakarta Velocity 1.3 Released
Date Mon, 22 Jul 2002 18:45:46 GMT
On 7/22/02 2:19 PM, "Jon Schewe" <schewe_jon@htc.honeywell.com> wrote:

> Geir Magnusson Jr. writes:
>> 
>> The Velocity community is proud to announce the release of v1.3 of the
>> Jakarta Velocity template engine.
>> 
>> Along with numerous minor fixes, this release includes
>> 
>>  o Automatic detection of Jakarta Log4j or Jakarta Avalon's logkit
>>    for standard logging.
>> 
>>  o "Application Attributes" allow applications to interact with custom
>>     components such as resource loaders, loggers, etc.
>> 
>>  o The Resource Manager and Resource Cache are now pluggable, allowing
>>    for customized implementations.
>> 
>>  o The User's Guide is available in Finnish, French, Spanish and English
>> 
>> Thanks all for the patience.
>> 
>> I think we should roll the current CVS head out as 1.4-rc1 to get some of
>> the fixes out and available.  And no, it won't be the same release cycle.
>> Apologies...
> 
> Unfortunatly it appears that bugs fixed previously in CVS came back in this
> release.  Most notably the following bug I sent to the list back in
> April and was fixed by grabbing the latest from CVS at that time.
> I have the following bit of text in a velocity template:
> #if (${OBJECT_TYPE} == "collection")
> /**
>  * Calls setIntersection with windowStart and windowEnd set to
>  * PCFunctions.MIN_VALUE and PCFunctions.MAX_VALUE, respectively.
>  * 
>  * @see #setIntersection(PC${NAME}StepFunction, long, long)
>  */
> #end
> 
> When I run Velocity on the file I get the following:
> [FATAL]: Problem merging template(Function): Encountered "Intersection" at
> line 1079, column 15.
> Was expecting one of:
>   "(" ...
>   <WHITESPACE> ...
> 
> I tried changing it to \#setIntersection, then my output contained the
> backslash as well.  Is there anyway around this, short of setting a variable
> to #set and using that in my template?
> 
> 

Yes - the fix for this will be in 1.4

We had started the 1.3 release process already, and it took a while. (And we
*still* missed a bug :)

So once the 1.3.1 is out (I need to roll the tarball tonight), then we can
do a 1.4-rc1 so this fix will get out there.

-- 
Geir Magnusson Jr. 
Research & Development, Adeptra Inc.
geirm@adeptra.com
+1-203-247-1713



--
To unsubscribe, e-mail:   <mailto:velocity-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:velocity-user-help@jakarta.apache.org>


Mime
View raw message