velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gabriel Sidler <sid...@teamup.com>
Subject Re: VelocityViewServlet and velocity.properties
Date Thu, 03 Oct 2002 04:47:15 GMT
Iain,
all templates are read relative to the root of the web app. There is
currently no way to configure the resource loader differently in
velocity.properties. That is maybe something we should add??

Gabe


Iain Young wrote:

> Hi folks, I'm hoping someone out there can help this velocity newbee...
>  
> I'm trying to use the VelocityViewServlet (in conjunction with struts) in my
> webapp, but am having a few problems in the configuration. I want to place
> the template vm files under a templates subdirectory, but despite changing
> the setting in the velocity.properties file, I always seem to get a
> "resource not found" error.
>  
> Strangely, if I create a "dummy" servlet with just a loadConfiguration
> method in it, and set this to load at startup, then VelocityViewServlet can
> find the files. Because of this, I'm guessing that there is probably
> something wrong with the VelocityViewServlet init routines, and running this
> dummy servlet beforehand is correctly loading the config. 
>  
> Anyone got any ideas as to what might be going wrong?
>  
> Thanks,
> Iain Young
> 
> 
> --
> To unsubscribe, e-mail:   <mailto:velocity-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:velocity-user-help@jakarta.apache.org>
> 
> .
> 
> 


-- 
--
Gabriel Sidler
Software Engineer, Eivycom GmbH, Zurich, Switzerland


--
To unsubscribe, e-mail:   <mailto:velocity-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:velocity-user-help@jakarta.apache.org>


Mime
View raw message