velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charles N. Harvey III" <charl...@alloy.com>
Subject RE: VelocityViewServlet and velocity.properties
Date Wed, 02 Oct 2002 15:16:53 GMT
Iain,
Where are your templates?  Are they located at /WEB-INF/?  If not then then
the WebappLoader will not pick them up.  Regular ol' velocity comes with a
bunch
of different resource loaders but the VVS has the WebappLoader hard-coded
into it.

I have changed the VVS on my machine to read the type of resource loader
from
a properties file.  Its a pretty easy change.


Charlie


> -----Original Message-----
> From: Iain Young [mailto:Iain.Young@microfocus.com]
> Sent: Wednesday, October 02, 2002 11:05 AM
> To: 'Velocity Users List'
> Subject: RE: VelocityViewServlet and velocity.properties
>
>
> Thanks Bill, but I'm using Tomcat at the moment so everything is exploded.
> Strangely, I've noticed that it seems to work if I remove these two lines
> from ViewVelocityServlet.initVelocity...
>
>     Velocity.setProperty( "resource.loader", "webapp" );
>     Velocity.setProperty( "webapp.resource.loader.class",
> "org.apache.velocity.tools.view.servlet.WebappLoader" );
>
> leading me to believe that the problem may be in the loader class?
>
> Cheers,
> Iain
>
>
> --
> To unsubscribe, e-mail:
> <mailto:velocity-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:velocity-user-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:velocity-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:velocity-user-help@jakarta.apache.org>


Mime
View raw message