velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Baynes" <kbay...@seagullsw.com>
Subject RE: Velocity newbie -- please help!
Date Tue, 01 Oct 2002 14:06:02 GMT
Damar~

Did you add the lib directories to the classpath, or did you add the JAR
files? If you just referenced the directory, try referencing the JAR
completely.

What does your classpath look like now?

~Kevin

> -----Original Message-----
> From: damar thapa [mailto:damar@netvigator.com]
> Sent: Tuesday, October 01, 2002 8:20 AM
> To: Velocity Users List
> Subject: Re: Velocity newbie -- please help!
>
>
> Hi,
>
> Thanks for your pointer.  I have installed tomcat, and put servlet.jar
> class into my CLASSPATH (I have put all lib directories into CLASSPATH
> too), but still the same message.
>
> Any other pointers?
>
> Thanks,
>
> Damar
>
> Bill Kaufman wrote:
>
> >I think you're missing the servlet APIs on your classpath.
> (There's a missing directory name in the classpath emitted by ANT.)
> >
> >If you've already got a servlet container (like Tomcat) on your
> machine, there should be a JAR file containing all the
> javax.servlet classes; otherwise, you can download the class
> files at http://java.sun.com/products/servlet/download.html .
> >
> >                                                      -- Bill K.
> >
> >
> >
> >
> >
> >>-----Original Message-----
> >>From: damar thapa [mailto:damar@netvigator.com]
> >>Sent: Monday, September 30, 2002 6:32 PM
> >>To: velocity-user@jakarta.apache.org
> >>Subject: Velocity newbie -- please help!
> >>
> >>
> >>Hi,
> >>
> >>I am trying to  setup velocity-1.3 on my debian-3.0.
> >>
> >>When I run 'ant' at /usr/src/velocity-1.3/build, I get the following
> >>message:
> >>
> >>env:
> >>     [echo] java.home = /usr/local/j2sdk1.4.1/jre
> >>     [echo] user.home = /root
> >>     [echo] java.class.path =
> >>/usr/local/ant/lib/xml-apis.jar:/usr/local/ant/lib/xercesImpl.
> >>jar:/usr/local/ant/lib/optional.jar:/usr/local/ant/lib/ant.jar
> >>::/usr/local/j2sdk1.4.1/lib:/usr/lib:/usr/local/j2sdk1.4.1/lib
> >>/velocity-1.3.jar:/usr/local/j2sdk1.4.1/lib:/usr/lib:/usr/loca
> >>l/j2sdk1.4.1/lib/tools.jar
> >>
> >>
> >>prepare:
> >>
> >>compile:
> >>    [javac] Compiling 1 source file to
> >>/usr/src/velocity-1.3/bin/classes
> >>    [javac]
> >>/usr/src/velocity-1.3/bin/src/org/apache/velocity/servlet/Velo
> >>cityServlet.java:296: cannot resolve symbol
> >>    [javac] symbol  : method getInitParameter (java.lang.String)
> >>    [javac] location: interface javax.servlet.ServletContext
> >>    [javac]             propsFile = config.getServletContext()
> >>    [javac]                                                 ^
> >>    [javac] 1 error
> >>
> >>BUILD FAILED
> >>file:/usr/src/velocity-1.3/build/build.xml:189: Compile
> >>failed; see the compiler error output for details.
> >>
> >>Total time: 12 seconds
> >>
> >>Can any one on the list give me some pointers on what is
> >>wrong here, and
> >>what I should do?
> >>
> >>Thanks.
> >>
> >>Damar
> >>
> >>
> >>--
> >>To unsubscribe, e-mail:
> >><mailto:velocity-user-unsubscribe@jakarta.apache.org>
> >>For additional commands, e-mail:
> >><mailto:velocity-user-help@jakarta.apache.org>
> >>
> >>
> >>
> >>
> >
> >--
> >To unsubscribe, e-mail:
> <mailto:velocity-user-unsubscribe@jakarta.apache.org>
> >For additional commands, e-mail:
> <mailto:velocity-user-help@jakarta.apache.org>
> >
> >
> >
> >
>
>
>
>
> --
> To unsubscribe, e-mail:
> <mailto:velocity-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:velocity-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:velocity-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:velocity-user-help@jakarta.apache.org>


Mime
View raw message