velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Borja Martín <bmar...@hola.com>
Subject Re: applications sharing the file.resource.loader.path
Date Tue, 05 Nov 2002 15:15:02 GMT
As I explained in the mail, I had already done it with no success...

Thx in advance.

----- Original Message -----
From: "Barbara Baughman" <baughman@utdallas.edu>
To: "Velocity Users List" <velocity-user@jakarta.apache.org>
Sent: Monday, November 04, 2002 8:29 PM
Subject: Re: applications sharing the file.resource.loader.path


Try putting the velocity jar in the WEB-INF/lib for each web
application.  You have evidently written for a singleton model, which
assumes only one Velocity engine.  If you put the jar in WEB-INF/lib there
will be one Velocity engine for each webapp.

Barbara Baughman
X2157

On Mon, 4 Nov 2002, [iso-8859-1] Borja Martín wrote:

> hi.
> I have the following problem(I'm not sure if it's a bug or an erroneus
configuration):
> I have several applications running on my server, but It seems that they
are sharing the Velocity.FILE_RESOURCE_LOADER_PATH, because they don't find
their templates in the directories I had specified in the
velocity.properties file(every application has it own velocity.properties),
but if I copy the templates to the templates' dir of the only application
that is running properly, they are found.
>
> Then, the first application I run after starting the webserver, it's the
one that will work fine, and whose templates directory is where the others
apps will look.
> I'm running Resin 2.1.5 (I also tried with 2.0.4-2.1.4) and I also deleted
the velocity-*.jar from the common lib directory and put it in every
WEB-INF/lib dir, as it's explained in the documentation.
>
> Any idea?
> Thx in advance.
>


--
To unsubscribe, e-mail:
<mailto:velocity-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:velocity-user-help@jakarta.apache.org>




--
To unsubscribe, e-mail:   <mailto:velocity-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:velocity-user-help@jakarta.apache.org>


Mime
View raw message