velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Borja Martín <bmar...@hola.com>
Subject applications sharing the file.resource.loader.path
Date Mon, 04 Nov 2002 16:47:07 GMT
hi.
I have the following problem(I'm not sure if it's a bug or an erroneus configuration):
I have several applications running on my server, but It seems that they are sharing the Velocity.FILE_RESOURCE_LOADER_PATH,
because they don't find their templates in the directories I had specified in the velocity.properties
file(every application has it own velocity.properties), but if I copy the templates to the
templates' dir of the only application that is running properly, they are found.

Then, the first application I run after starting the webserver, it's the one that will work
fine, and whose templates directory is where the others apps will look.
I'm running Resin 2.1.5 (I also tried with 2.0.4-2.1.4) and I also deleted the velocity-*.jar
from the common lib directory and put it in every WEB-INF/lib dir, as it's explained in the
documentation.

Any idea?
Thx in advance.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message