velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rodolfo Sikora" <rodo...@oktiva.com.br>
Subject Re: Problems testing Velocity
Date Mon, 02 Dec 2002 03:33:35 GMT
Hi,
I followed your recomendations, and got same errors:

C:\velocity-1.3.1-rc2\build>\ant\bin\ant test
Buildfile: build.xml

env:
     [echo] java.home = C:\j2sdk1.4.1\jre
     [echo] user.home = C:\Documents and Settings\vo0do0
     [echo] java.class.path =
C:\j2sdk1.4.1\lib\tools.jar;C:\ant\bin\..\lib\xml-
apis.jar;C:\ant\bin\..\lib\xercesImpl.jar;C:\ant\bin\..\lib\optional.jar;C:\
ant\
bin\..\lib\ant.jar;


prepare:

compile:

compile-copy:

test:

test-template:
     [echo] Running Template tests...
     [java] java.lang.NoClassDefFoundError: junit/framework/TestCase
     [java]     at java.lang.ClassLoader.defineClass0(Native Method)
     [java]     at java.lang.ClassLoader.defineClass(ClassLoader.java:502)
     [java]     at
java.security.SecureClassLoader.defineClass(SecureClassLoader
.java:123)
     [java]     at
java.net.URLClassLoader.defineClass(URLClassLoader.java:250)
     [java]     at
java.net.URLClassLoader.access$100(URLClassLoader.java:54)
     [java]     at java.net.URLClassLoader$1.run(URLClassLoader.java:193)
     [java]     at java.security.AccessController.doPrivileged(Native
Method)
     [java]     at
java.net.URLClassLoader.findClass(URLClassLoader.java:186)
     [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
     [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
     [java]     at
java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315)

     [java]     at java.lang.ClassLoader.defineClass0(Native Method)
     [java]     at java.lang.ClassLoader.defineClass(ClassLoader.java:502)
     [java]     at
java.security.SecureClassLoader.defineClass(SecureClassLoader
.java:123)
     [java]     at
java.net.URLClassLoader.defineClass(URLClassLoader.java:250)
     [java]     at
java.net.URLClassLoader.access$100(URLClassLoader.java:54)
     [java]     at java.net.URLClassLoader$1.run(URLClassLoader.java:193)
     [java]     at java.security.AccessController.doPrivileged(Native
Method)
     [java]     at
java.net.URLClassLoader.findClass(URLClassLoader.java:186)
     [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
     [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:292)
     [java]     at
sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:265)

     [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
     [java]     at
java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315)

     [java]     at java.lang.Class.forName0(Native Method)
     [java]     at java.lang.Class.forName(Class.java:140)
     [java]     at
junit.runner.StandardTestSuiteLoader.load(StandardTestSuiteLo
ader.java:11)
     [java]     at
junit.runner.BaseTestRunner.loadSuiteClass(BaseTestRunner.jav
a:135)
     [java]     at
junit.runner.BaseTestRunner.getTest(BaseTestRunner.java:32)
     [java]     at junit.textui.TestRunner.start(TestRunner.java:233)
     [java]     at junit.textui.TestRunner.main(TestRunner.java:112)
     [java] Exception in thread "main"

BUILD FAILED
file:C:/velocity-1.3.1-rc2/build/testcases.xml:82: Java returned: 1

Total time: 2 seconds
C:\velocity-1.3.1-rc2\build>


----- Original Message -----
From: "Peter Romianowski" <megapero@gmx.de>
To: "'Velocity Users List'" <velocity-user@jakarta.apache.org>
Sent: Friday, November 29, 2002 9:00 AM
Subject: RE: Problems testing Velocity


I'm using ant 1.5.1 and it works really well!

>From the original post I see your initial Classpath is:

C:\j2sdk1.4.1\lib\tools.jar;c:\ant\lib\xml-apis.ja
r;c:\ant\lib\xercesImpl.jar;c:\ant\lib\optional.jar;c:\ant\lib\ant.jar;C
:\expres
so\webapps\ROOT\WEB-INF\lib\junit.jar

  Perhaps there's a collision between your junit.jar (C:\expres
so\webapps\ROOT\WEB-INF\lib\junit.jar) and the one that will
be added by the build script (lib/junit-3.7.jar). Please
to remove your junit.jar from classpath and try again.

Peter


--
To unsubscribe, e-mail:   <mailto:velocity-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:velocity-user-help@jakarta.apache.org>


Mime
View raw message