velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Lamuette" <turbine.lammel...@laposte.net>
Subject RE: Log4j Problem
Date Thu, 03 Apr 2003 16:02:24 GMT
I'm sorry Nathan, but it doesnt work for me. I've added :
"log4j.logger.org.apache.velocity=DEBUG, stdout" in my log4j.properties.
Nothing appears in the console... :-(
I'm using Log4j 1.2.8 and the last version of velocity 1.3.1 final


-----Message d'origine-----
De : Nathan Bubna [mailto:nathan@esha.com]
Envoyé : jeudi 3 avril 2003 17:08
À : Velocity Users List
Objet : Re: Log4j Problem


Richard said:
> I'm using Tomcat+Struts+Velocity+Velocity-Tools.
> It's not possible to use Log4J ?

it is possible.  i do it all the time, but it's not set up to "auto-detect"
log4j and use it.  you have to specify that you want Velocity to use log4j
in your velocity.properties.  something like this is appropriate:

runtime.log.logsystem.class =
org.apache.velocity.runtime.log.SimpleLog4JLogSystem
runtime.log.logsystem.log4j.category = org.apache.velocity

Nathan Bubna
nathan@esha.com


---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


Mime
View raw message