velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Bubna <nat...@esha.com>
Subject Re: TilesTool problem
Date Fri, 09 Jan 2004 20:20:12 GMT
Andrei Ivanov said:
> On Fri, 9 Jan 2004, Nathan Bubna wrote:
> > Andrei Ivanov said:
> > > Hello,
> > > I seem to have some problems using TilesTool.
> > ...
> > > In header.vm:
> > >
> > > ${tiles.getString("headerPictureNo")}
...
> > > In the logs I get:
...
> > > ${tiles.getString("headerPictureNo")} is not a valid reference.
> > >
> > > So this means that the getString() call is wrong and the get() call is
ok?
> > ...
> >
> > what version of VelocityTools are you using?  1.1-beta? or did you build
it
> > from CVS recently?
> >
> > i ask because after 1.1-beta, we realized that wasn't the best
> > method/name and changed it to getAttribute().
>
> wheee... it works... thank you. I will check the sources from now on, but
> maybe the docs should be updated ?

hmm.   i've gone back and forth on this.  i'm not sure whether they should
match the latest release or the latest CVS.  people building from CVS can
easily build the javadocs and people downloading releases get the release's
javadocs at part of the release.  so i'm not really sure who the online docs
are for.

if nothing else, i can say that the javadocs online do identify themselves as
being for 1.1-beta1.  also, the changes since 1.1-beta are listed online in
the change log (which i do keep mostly up to date).

Nathan Bubna
nathan@esha.com


---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


Mime
View raw message