velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Will Glass-Husain" <wgl...@forio.com>
Subject Re: Re[2]: Velocity.init() problem
Date Mon, 05 Jan 2004 15:40:34 GMT
No, Velocity is definitely 1.3 compatible.  A couple of quick thoughts...

Just as a side note, you have an extra "web" directory in the first one, is
that's legit?

Does your app have permissions to read the files?

Are you running under an unduly restrictive security manager?

WILL

----- Original Message ----- 
From: "Algirdas M." <snk@splius.lt>
To: "Velocity Users List" <velocity-user@jakarta.apache.org>
Sent: Monday, January 05, 2004 4:12 AM
Subject: Re[2]: Velocity.init() problem


> Hello Will,
>
> Sunday, January 4, 2004, 10:56:34 PM, you wrote:
>
> WGH> Have you done a logging or System.out.println on the value returned
by
> WGH> getServletContext().getRealPath("templates/")) to make sure it is the
same
> WGH> under both systems?
>
> in local system it is F:\projects\vvv\web\templates
> in server: /usr/share/tomcat4/webapps/vvv/templates
>
> both directories exists and have same files..
> maybe velocity requires bigger version of J2SE than 1.3?
>
> WGH> I browsed Bugzilla briefly and there were a few bugs in getRealPath
in early
> WGH> versions of Tomcat 4.0.x.  None seemed to apply directly to your
situation,
> WGH> but I advise checking to see if the path is generated correctly.
>
> WGH> WILL
>
>
>
>
> -- 
> Best regards,
>  Algirdas                            mailto:snk@splius.lt
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: velocity-user-help@jakarta.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


Mime
View raw message