velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shapira, Yoav" <Yoav.Shap...@mpi.com>
Subject RE: NullPointerException in setDefaultProperties
Date Wed, 21 Jan 2004 18:16:54 GMT

Howdy,

>This is a shot in the dark but give it a try..
>after instantiating the VelocityEngine object(as ve in this cas) insert
>this
>line of code
>
>ve.setProperty( VelocityEngine.RUNTIME_LOG_LOGSYSTEM, this);
>
>and then ve.init()

That doesn't help: I get the same NullPointerException.

I'm baffled as to why the ClassLoader returned from
RuntimeInstance ri = new RuntimeInstance();
ClassLoader loader = ri.getClass().getClassLoader();
is null.  I don't think it's the bootstrap classloader.  I'm using a
normal java command to run the program, just java com.myclass, with the
CLASSPATH set as an environment variable.

Yoav Shapira



This e-mail, including any attachments, is a confidential business communication, and may
contain information that is confidential, proprietary and/or privileged.  This e-mail is intended
only for the individual(s) to whom it is addressed, and may not be saved, copied, printed,
disclosed or used by anyone else.  If you are not the(an) intended recipient, please immediately
delete this e-mail from your computer system and notify the sender.  Thank you.


---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


Mime
View raw message