velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shinobu Kawai <shin...@ieee.org>
Subject malfunction in xdoc to html conversion for VelocityTools?
Date Thu, 08 Jul 2004 00:42:03 GMT

Hi!

I'm not sure where I should post this, but here seems the best to me...

I'm helping translating the VelocityTools documentation to Japanese at
    http://www.jajakarta.org/velocity/tools/
and I've found some weird stuff in the HTML documents.

In the xdocs, when there are <code> tags within the <abstract> element
of the tool method, the context of the <code> element does not show up
in the Method Overview section of the HTML.

For example, if you take a look at the xdoc for CookieTool#getAll(), you
will see
    <abstract>
        Expose array of <code>Cookie</code> objects for this request to the
        template.
    </abstract>
    (http://cvs.apache.org/viewcvs.cgi/jakarta-velocity-tools/xdocs/view/CookieTool.xml?rev=1.1&view=auto)
but in the HTML's "Method Overview", you will see
    Expose array of objects for this request to the template.
    (http://jakarta.apache.org/velocity/tools/view/CookieTool.html)
The "Cookie" is gone!

So either the <code> tag shouldn't be there in the first place, or the
xdoc to html conversion isn't processing it correctly.

Any clue?

TIA,
Shinobu Kawai

--
Shinobu Kawai <shinobu@ieee.org, shinobu@computer.org>


---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


Mime
View raw message