velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shinobu Kawai <shinobu.ka...@gmail.com>
Subject Re: ant DVSL task can't find VM_global_library.vm
Date Wed, 10 Nov 2004 03:42:44 GMT

Hi Larry,

Some clarifications.  :)

> I'm a bit confused by that statement, because an absolute path (e.g.
> C:\...) should resolve to the same resource regardless of the current
> directory.  In any case, the error message " [dvsl] [error]
> ResourceManager : unable to find resource
> 'C:\Views\lsiden_view_2\sdm_svc\SDMservices\GKN\Phase2\DeveloperRepository\veltemplate\VM_global_library.vm'
> in any resource loader." shows clearly what the ResourceManager was looking for.
One misunderstanding:  the FileResourceLoader can only find resources via
relative paths.  It doesn't deal with absolute paths.

The error message is saying, the _resource_ "C:\Views\...library.vm" was
not found.  Not the _file_.  If your current directory was
"C:\Views\...\DeveloperRepository", the FileResourceLoader will be
actually looking for:
    C:\Views\...\DeveloperRepository\C:\Views\...library.vm
## Okay, so it wouldn't even work if your current directory was C:\

> FWIW, I think I already tried converting the '\' to '/' AND tried it
> both with and without the ${basedir}/ appended, but I'll give both
> another shot when I get into work tomorrow.
One more thing.  Are you calling Ant from
C:\Views\...\DeveloperRepository?

Of course, I'm just guessing about DVSL, but I know all this is true
about Velocity.  B)

Best regards,
-- Shinobu Kawai

--
Shinobu Kawai <shinobu.kawai@gmail.com>


---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


Mime
View raw message