velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shinobu Kawai Yoshida <shinobu.ka...@gmail.com>
Subject Re: anakia question and possible problem
Date Tue, 18 Jan 2005 15:07:56 GMT
Hi Mike,

> Having problems getting anakia to transform $root.getChild calls..
> 
> I have the following xml data file

## snip

> And the following vsl file (marked by !!! problem is here)

## snip

> and finally the following java code

## snip

> When I execute the code and debug, I see the files get loaded and the
> merge, flush and close work fine.
> However, my output html still has the literal string
> 
> "$root.getChild("foo").getText()
> 
> embedded in it. when I check the log I see the following message
> 
> "reference : template = StartPage.vsl [line 10,column 17] :
> "$root.getChild("foo").getText() is not a valid reference.
> 
> I have tried every variation of xml and $root command I can think of
> and they all give me the same error. The only thing that doesn't produce
> an
> error is if I just have $root.
> 
> any Idea why my getChild() call isn't working?

You need to execute Anakia via the Ant task.  What you are doing here
is processing Velocity via normal java application.
   http://jakarta.apache.org/velocity/anakia.html
## BTW, I think you can get it to work by putting
root.getRootElement() in the Context as "root"

> Also, anyone have any other examples of using anakia, I can only find one
> that comes with the SDK...bah.

Many of the Jakarta project sites (including Velocity, of course :)) use Anakia.
## Although there is a movement towards XSLT.
   http://jakarta.apache.org/site/jakarta-site2.html

Best regards,
-- Shinobu

--
Shinobu "Kawai" Yoshida <shinobu.kawai@gmail.com>

---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


Mime
View raw message