velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tanveer Dhillon" <tanveer.dhil...@secf.com>
Subject Re: frames
Date Tue, 22 Mar 2005 06:43:33 GMT
the frame set close tag is there but soory there was aproblem in copying 
it.
I tried using frames in a simple velocity page but they aren't working 
too.
though when i view source from the browser its perfectly fine.
What could be the problem ?
thanks again
tanveer

-----Original Message-----
From: "Will Glass-Husain" <wglass@forio.com>
To: "Velocity Users List" <velocity-user@jakarta.apache.org>
Date: Mon, 21 Mar 2005 13:24:37 -0800
Subject: Re: frames

> where's the close of the frameset?
> 
> Also, what happens if you type that URL directly into the browser?
> 
> <root of the original 
> webpage>/compensation/workstream/template/screens%2Fsample.html;jsessio
> nid=DBA5C695A26902DF3ED7087D6466E853"
> 
> WILL
> 
> ----- Original Message ----- 
> From: "Tanveer Dhillon" <tanveer.dhillon@secf.com>
> To: "Velocity Users List" <velocity-user@jakarta.apache.org>
> Sent: Monday, March 21, 2005 5:27 AM
> Subject: RE: frames
> 
> 
> > hi thankyou for the help.
> > I have joined the turbine list.
> > when i click on the "view source " in the browser i see the
> > <frameset rows="70,*">
> > <frame
> >
> src="/compensation/workstream/template/screens%2Fsample.html;jsessionid
> =DBA5
> > C695A26902DF3ED7087D6466E853" >
> > <frame
> >
> src="/compensation/workstream/template/screens%2Ftry.txt;jsessionid=DBA
> 5C695
> > A26902DF3ED7087D6466E853" >
> >
> > but the frames dont appear.
> > thanks again
> > tanveer
> >
> > -----Original Message-----
> > From: Will Glass-Husain [mailto:wglass@forio.com]
> > Sent: Monday, March 21, 2005 12:43 PM
> > To: Velocity Users List
> > Subject: Re: frames
> >
> >
> >
> >
> > (1) If the frames don't appear in the browser, what do you see when
> you
> > click "View Source"?
> >
> > (2) If you make a simple page with the word "test" in it, does that
> appear
> > in the browser?
> >
> > Sounds like it's not a frame issue, but a problem getting the pages
> to
> > display.
> >
> > Come to think of it, you may want to take this to the Turbine list
> for 
> > more
> > help - they'll be
> > able to assist in getting this set up.
> >
> > WILL
> >
> > ----- Original Message -----
> > From: "Tanveer Dhillon" <tanveer.dhillon@secf.com>
> > To: "Velocity Users List" <velocity-user@jakarta.apache.org>
> > Sent: Sunday, March 20, 2005 10:55 PM
> > Subject: frames
> >
> >
> >> yeah actually io used the frameset tag in the vm page and also set
> >> layout.default in tubineresource.properties as
> >> layout.default=VelocityOnlyLayout, but the frames dont appear in the
> >> browser. Also i tried using #parse("header.vm") in the vm page but
> it
> >> displays the error.vm page. I cant seem to understand the reasons.
> >> I shall be really thankful for the help
> >> tanveer
> >>
> >> -----Original Message-----
> >> From: Will Glass-Husain [mailto:wglass@forio.com]
> >> Sent: Monday, March 21, 2005 12:20 PM
> >> To: Velocity Users List; Shinobu Kawai
> >> Subject: Re: Resource Not Found Exception
> >>
> >>
> >> I've built web apps with frames using Velocity (without Turbine,
> though
> >> I've
> >> built non-frame apps with Turbine).
> >>
> >> There's really nothing special about Velocity or Turbine with
> reference 
> >> to
> >> frames.    Standard HTML and JavaScript techniques apply.  Is there
> >> something in particular you're having trouble with?
> >>
> >> WILL
> >>
> >>
> >> ----- Original Message -----
> >> From: "Tanveer Dhillon" <tanveer.dhillon@secf.com>
> >> To: "Velocity Users List" <velocity-user@jakarta.apache.org>;
> "Shinobu
> >> Kawai" <shinobu.kawai@gmail.com>
> >> Sent: Sunday, March 20, 2005 10:43 PM
> >> Subject: RE: Resource Not Found Exception
> >>
> >>
> >>> hi...
> >>> please guide me on using frames in velocity.
> >>> I m a very new user to velocity and would like to create beautiful
> pages
> >>> using velocity. I m using turbine with velocity.
> >>> kindly suggest
> >>> tanveer
> >>>
> >>>
> >>> -----Original Message-----
> >>> From: Shinobu Kawai [mailto:shinobu.kawai@gmail.com]
> >>> Sent: Friday, March 18, 2005 11:29 PM
> >>> To: Velocity Users List
> >>> Subject: Re: Resource Not Found Exception
> >>>
> >>>
> >>> Hi Elton,
> >>>
> >>>> First, I am very new to Velocity. I have installed it and I ran
> 'ant
> >>>> test' and it came back successful.
> >>>
> >>> Welcome to Velocity-World and congratulations on a working copy of
> >>> Velocity!
> >>> :)
> >>>
> >>>> I am learning Velocity by reading
> >>>> 'Pro Jakarta Velocity' by Rob Harrop. In the first example
> program, I
> >>>> entered:
> >>>
> >>> ## snip
> >>>
> >>>>                // initialize Velocity
> >>>>                Velocity.init();
> >>>>
> >>>>                // get the template
> >>>>                Template template =
> >>>> Velocity.getTemplate("classes/templates/ch02/HelloWorld.vm");
> >>>
> >>> ## snip
> >>>
> >>>> It compiles, but when I run the program I get:
> >>>>
> >>>> ----------
> >>>> -> java org.novaworks.ch02.HelloWorld
> >>>> Exception in thread "main"
> >>>> org.apache.velocity.exception.ResourceNotFoundException: Unable to
> find
> >>>> resource 'classes/templates/ch02/HelloWorld.vm'
> >>>
> >>> ## snip
> >>>
> >>>> I know Velocity works because I am able to run the first example
> >>>> program that came with the distribution. Any thoughts on what is
> not
> >>>> happening?
> >>>
> >>> 1. Where are you running HelloWorld?
> >>> 2. What are your resource loader settings in the
> velocity.properties?
> >>> 3. Where is the HelloWorld.vm?
> >>>
> >>> Some more to help:
> >>>
> >>>
> >>
> >
> http://jakarta.apache.org/velocity/developer-guide.html#Configuring%20R
> esour
> >>> ce%20Loaders
> >>>
> >>> Best regards,
> >>> -- Shinobu
> >>>
> >>> --
> >>> Shinobu Kawai <shinobu.kawai@gmail.com>
> >>>
> >>>
> ---------------------------------------------------------------------
> >>> To unsubscribe, e-mail:
> velocity-user-unsubscribe@jakarta.apache.org
> >>> For additional commands, e-mail:
> velocity-user-help@jakarta.apache.org
> >>>
> >>>
> >>>
> >>>
> >>>
> >>>
> >>>
> ---------------------------------------------------------------------
> >>> To unsubscribe, e-mail:
> velocity-user-unsubscribe@jakarta.apache.org
> >>> For additional commands, e-mail:
> velocity-user-help@jakarta.apache.org
> >>>
> >>
> >>
> >>
> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
> >> For additional commands, e-mail:
> velocity-user-help@jakarta.apache.org
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
> >> For additional commands, e-mail:
> velocity-user-help@jakarta.apache.org
> >>
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail:
> velocity-user-help@jakarta.apache.org
> >
> >
> >
> >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail:
> velocity-user-help@jakarta.apache.org
> > 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: velocity-user-help@jakarta.apache.org
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


Mime
View raw message