velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jill han" <j...@bynum.com>
Subject RE: applet
Date Mon, 09 May 2005 21:25:12 GMT
All right, it seems that I have to separate codebase and code attribute
in the applet tag like:

<table cellpadding=0 cellspacing=0 border=0 width="808"> 
  <APPLET CODEBASE='$content.getURI("applet/")'  
      	code = 'Star.class'  WIDTH = 300 HEIGHT = 300>  
  </APPLET> 
    	 
</table>

It will show up. But I don't know why.

Thanks for you helps.

Jill
-----Original Message-----
From: Shinobu Kawai [mailto:shinobu.kawai@gmail.com] 
Sent: Monday, May 09, 2005 3:57 PM
To: Velocity Users List
Subject: Re: applet

Hi jill,

> I moved Star.class to the folder where the template sits. And change
the
> applet tag to
> 
> <table cellpadding=0 cellspacing=0 border=0 width="808">
> <APPLET CODE='Star.class' WIDTH = 300 HEIGHT = 300>  </APPLET>
> </table>
> 
> The message from Jave Console is like:

## snip

> java.lang.ClassFormatError: Star (Bad magic number)

Something definitely messed up your class file.
 
http://java.sun.com/j2se/1.4.2/docs/api/java/lang/ClassFormatError.html

I suggest that you first test your applet without Velocity, and move
on to Velocity once you get it working.

Best regards,
-- Shinobu

--
Shinobu Kawai <shinobu.kawai@gmail.com>

---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


Mime
View raw message