velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Bubna <nbu...@gmail.com>
Subject Re: syntax issue
Date Mon, 22 Aug 2005 15:31:11 GMT
None of these will be deprecated and preference is a matter of both
taste and use.  Formal notation (${bar.foo} or ${bar.getFoo()}) is
good for separating your variables from the content next to them. 
Typing out the whole method ($bar.getFoo()) is good for speed (though
barely) and specificity.  Shorthand notation ($bar.foo or $bar.Foo) is
less keystrokes, more readable, and more flexible.  Choose them
depending on your needs and goals.

On 8/22/05, Bayarsaikhan VOLODYA <bayarsaikhan@gmail.com> wrote:
> Hi all,
> 
> which syntax is more suitable (or will not be deprecated) preferrable than
> the other one?
> 
> ${name.firstName}
> or
> $name.firstName
> or
> $name.getFirstName()
> 
> thanks in advance.
> 
> --
> Bayarsaikhan VOLODYA
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


Mime
View raw message