velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathan Bubna" <nbu...@gmail.com>
Subject Re: DataSourceResourceLoader not support UTF8?
Date Sat, 07 Jun 2008 15:57:41 GMT
It looks that way.  Not sure why that is; I don't use that resource
loader myself.  Patches are, of course, welcome on the
dev@velocity.apache.org list if you decide to take a crack at fixing
that. :)  I'm afraid i don't have any time to help there.

On Thu, Jun 5, 2008 at 9:23 PM, markchen <gxchenme@yahoo.com> wrote:
>
> Environment : springMVC(2.5) + Velocity(1.5) + oracle10g(characterset UTF8).
>
> I realize that if templates are stored in the database instead of files,
> the characters retrived becomes garbled.
>
> Is it a bug?
>
> DataSourceResourceLoader#getResourceStream(...)
>
> :::
> InputStream ascStream = rs.getAsciiStream(templateColumn);
>                                       ^^^^^^^^^
> :::
>
> regards,
> --
> View this message in context: http://www.nabble.com/DataSourceResourceLoader-not-support-UTF8--tp17684375p17684375.html
> Sent from the Velocity - User mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@velocity.apache.org
> For additional commands, e-mail: user-help@velocity.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@velocity.apache.org
For additional commands, e-mail: user-help@velocity.apache.org


Mime
View raw message