velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathan Bubna" <nbu...@gmail.com>
Subject Re: Not understanding something
Date Tue, 24 Jun 2008 02:40:56 GMT
On Mon, Jun 23, 2008 at 7:37 PM, Nathan Bubna <nbubna@gmail.com> wrote:
> Are you using ImportTool or TilesTool?  These do internal request
> forwarding.  I'm no expert on all that happens when servlets do
> request forwarding (see the ImportSupport class they both extend for
> implementation details), so i don't know offhand if these would be
> visible to the bot or if they just show up in Tomcat's logs.  My guess
> is that the bot wouldn't see these, as they are forwards, not
> redirects.

excuse me, i believe the term is "includes" not "forwards".   it's
done using the javax.servlet.RequestDispatch class' include(request,
response) method, where the response is wrapped to grab the content.

> On Mon, Jun 23, 2008 at 7:08 PM, johne <jeichels@yahoo.com> wrote:
>>
>> I have been using Velocity for a long time.  I am seeing something odd.  I
>> was trying to remove jsession ids from non-user accounts (bots) by removing
>> the URL rewriting in a tomcat 6.0 filter.  I then just had this filter print
>> out debug information for bots coming in and the URL they see.  I see
>> something to the affect of this in my debug log:
>>
>> INFO  [080620 23:47:13] Spider User Agent (msnbot/1.1
>> (+http://search.msn.com/msnbot.htm)) looking at page:
>> http://mydomain.com/action/pub/my-listing
>> INFO  [080620 23:47:13] Spider User Agent (msnbot/1.1
>> (+http://search.msn.com/msnbot.htm)) looking at page:
>> http://mydomain.com/WEB-INF/templates/common/myMainTemplate.vm
>>
>>
>> Though I have one debug message printing out, I was only expecting to see
>> the first debug message to print out.  The second message is very
>> unexpected.  It is the template that was being used to render page the bot
>> was looking at.
>>
>> Why would this message show up if using Velocity along with Tiles/Struts?
>>
>> I even have access control prevented in this template directory so very
>> weird.  I must be missing something.
>>
>> All the pages look great, I just would not want bots to pick up on things
>> they should not see.
>>
>> Regards,
>>
>> John
>>
>>
>> -----
>> JohnE
>>
>> http://www.jobbank.com jobbank.com
>> --
>> View this message in context: http://www.nabble.com/Not-understanding-something-tp18082309p18082309.html
>> Sent from the Velocity - User mailing list archive at Nabble.com.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@velocity.apache.org
>> For additional commands, e-mail: user-help@velocity.apache.org
>>
>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@velocity.apache.org
For additional commands, e-mail: user-help@velocity.apache.org


Mime
View raw message