velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Bubna <nbu...@gmail.com>
Subject Re: org.apache.velocity.runtime.log.Log4JLogChute initialization failed
Date Thu, 19 Feb 2009 15:17:00 GMT
There should be a stack trace that went with that message.  What did
it say?  Also, do you have log4j on your classpath?  If so, what
version?

On Thu, Feb 19, 2009 at 4:49 AM, Chachad, Ketan
<Ketan.Chachad@atosorigin.com> wrote:
> Hi,
>
>
>
> I have used Velocity in my web application.
>
> I am not using any "velocity.properties" file as loading the file was
> becoming a problem.
>
> So to initialize VelocityEngine the code used is as follows:
>
> VelocityEngine ve = new VelocityEngine();
>
> ve.setProperty("resource.loader", "webapp");
>
> ve.setProperty("webapp.resource.loader.class","org.apache.velocity.tools
> .view.servlet.WebappLoader");
>
> ve.setProperty("webapp.resource.loader.path","/WEB-INF/templates/");
>
> ve.setApplicationAttribute("javax.servlet.ServletContext",this.servlet.g
> etServletContext());
>
> ve.init();
>
>
>
> While the web application works fine on my local host, but when it was
> deployed on to the test application server, it gave the following error
>
> Error Code            500
>
> Message                Failed to initialize an instance of
> org.apache.velocity.runtime.log.Log4JLogChute with the current runtime
> configuration.
>
>
>
> Can anyone tell me what needs to be done to avoid this error?
>
>
>
> Regards,
>
> Ketan K. Chachad | Atos Origin India | Tower I - France |
> ketan.chachad@atosorigin.com <mailto:ketan.chachad@atosorigin.com>  | D:
> +91 22 67 33 34 63 | M: +91 98 19 17 02 71
>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@velocity.apache.org
For additional commands, e-mail: user-help@velocity.apache.org


Mime
View raw message