velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chachad, Ketan" <Ketan.Chac...@atosorigin.com>
Subject org.apache.velocity.runtime.log.Log4JLogChute initialization failed
Date Thu, 19 Feb 2009 12:49:12 GMT
Hi,

 

I have used Velocity in my web application. 

I am not using any "velocity.properties" file as loading the file was
becoming a problem.

So to initialize VelocityEngine the code used is as follows:

VelocityEngine ve = new VelocityEngine();

ve.setProperty("resource.loader", "webapp");

ve.setProperty("webapp.resource.loader.class","org.apache.velocity.tools
.view.servlet.WebappLoader");

ve.setProperty("webapp.resource.loader.path","/WEB-INF/templates/");

ve.setApplicationAttribute("javax.servlet.ServletContext",this.servlet.g
etServletContext());

ve.init();

 

While the web application works fine on my local host, but when it was
deployed on to the test application server, it gave the following error

Error Code            500

Message                Failed to initialize an instance of
org.apache.velocity.runtime.log.Log4JLogChute with the current runtime
configuration.

 

Can anyone tell me what needs to be done to avoid this error?

 

Regards,

Ketan K. Chachad | Atos Origin India | Tower I - France |
ketan.chachad@atosorigin.com <mailto:ketan.chachad@atosorigin.com>  | D:
+91 22 67 33 34 63 | M: +91 98 19 17 02 71

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message