velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aruna Venkataraman <aruna_...@yahoo.co.uk>
Subject Re: Is junit-3.8.1.jar optional for Velocity as specified in jar dependencies?
Date Tue, 02 Jun 2009 11:16:25 GMT
Great, thats a better approach for fixing this issue. Thanks.
 
Regards,
Aruna

--- On Tue, 2/6/09, Claude Brisson <claude@renegat.net> wrote:


From: Claude Brisson <claude@renegat.net>
Subject: Re: Is junit-3.8.1.jar optional for Velocity as specified in jar dependencies?
To: "Velocity Users List" <user@velocity.apache.org>
Date: Tuesday, 2 June, 2009, 4:41 PM


It would also probably have been fixed if you had upgraded ant, junit is
included in recent versions of ant.

  Claude

On mar., 2009-06-02 at 11:04 +0000, Aruna Venkataraman wrote:
>  Build fails for velocity-1.6.2 on invoking ant command. I am not testing, i just wanted
to build Velocity 1.6.2.
>  
> Got fixed after downloading and copying junit.jar into ANT_HOME/lib. The solution is
pretty easy but spent a lot of time on it as i didn't know we need to copy/paste this junit.jar
into ANT_HOME/lib for the build of velocity to be successful.
>  
> Regards,
> Aruna
>  
> 
> --- On Tue, 2/6/09, Claude Brisson <claude@renegat.net> wrote:
> 
> 
> From: Claude Brisson <claude@renegat.net>
> Subject: Re: Is junit-3.8.1.jar optional for Velocity as specified in jar dependencies?
> To: "Velocity Users List" <user@velocity.apache.org>
> Date: Tuesday, 2 June, 2009, 4:28 PM
> 
> 
> junit required for tests but not to build Velocity. You can specify a
> target argument to ant, just run 'ant -p'. The default target will run
> tests, so will download it again, so I don't understand why you got this
> error. What are you exactly trying to achieve?
> 
>   Claude
> 
> On mar., 2009-06-02 at 05:56 +0000, Aruna Venkataraman wrote:
> > When i navigate to the build directory in Velocity 1.6.2 and invoke
> > "ant" then the below error is got:
> > Could not create task or type of type: junit. lib\test. 
> > Ant could not find the task or a class this task relies upon.
> > 
> > I deleted the junit-3.8.1.jar file from bin\test-lib as it was
> > specified to be optional, but it gets created automatically.  Do we
> > need to remove the dependency on this junit-3.8.1.jar manually? 
> >  
> > Refer Screenshot "build_fails" attached.
> > 
> >  
> > Regards,
> > Aruna
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@velocity.apache.org
> > For additional commands, e-mail: user-help@velocity.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@velocity.apache.org
> For additional commands, e-mail: user-help@velocity.apache.org
> 
> 
> 
> 
>       


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@velocity.apache.org
For additional commands, e-mail: user-help@velocity.apache.org




      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message