velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Bubna <nbu...@gmail.com>
Subject Re: Getting Velocity working with Google App Engine
Date Sun, 25 Sep 2011 20:33:43 GMT
tools.xml is supported by the VelocityTools project.  make sure you
include a current VelocityTools jar.

On Sun, Sep 25, 2011 at 12:51 PM, Andrew Ducker <andrew@ducker.org.uk> wrote:
> I'm plugging away at this, because I'd like to use Velocity for the
> templates in the app I'm working on.
>
> I've got part of the way there*, but seem to be having a problem with the
> tools.xml file.
>
> The pieces that don't depend on the tools.xml seem to work ok.  For
> instance,
> Lets count : #foreach($i in [1..5])$i #end
> comes out as
> Lets count : 1 2 3 4 5
>
> but if it tries to use any of the variable in the tools.xml then I get
> something like:
> This is simple app version ${version}.
> or
> Here we use a custom tool: $toytool.message
>
> Is there something I need to set to get it running with the tools.xml file?
>  I've got it sitting in the WEB-INF folder, and it's a copy straight from
> the tutorial.
>
> Any ideas?
>
> Thanks,
>
> Andy
>
>
> *I had to add the following to the appengine-web.xml:
> <static-files>
>    <exclude path="/**.vm" />
> </static-files>
> and create an empty velocity.properties to the web-inf folder in order to
> not get exceptions or other oddness.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@velocity.apache.org
> For additional commands, e-mail: user-help@velocity.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@velocity.apache.org
For additional commands, e-mail: user-help@velocity.apache.org


Mime
View raw message